summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonin Décimo2020-12-07 18:44:18 +0100
committerAntonin Décimo2020-12-07 18:46:36 +0100
commit288c1f7eb298462bd73c06673994009b73dc396b (patch)
tree318d33b186123a491e7cabe5122f65832814b3e3
parent84f0f4d575a2620f328ea50816db835fc299ea08 (diff)
downloadaur-288c1f7eb298462bd73c06673994009b73dc396b.tar.gz
Update to Opam 2.1.0.beta2
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD43
-rw-r--r--opam-git.install3
4 files changed, 35 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e93f3ee202ea..9518c04cb73c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = opam-git
- pkgdesc = OCaml Package Manager
- pkgver = 1.1.0.484.g692cf53
+ pkgdesc = OCaml package manager
+ pkgver = 2.1.0.beta2.r165.g1138d481
pkgrel = 1
- url = https://opam.ocaml.org
- install = opam-git.install
+ url = https://opam.ocaml.org/
arch = i686
arch = x86_64
arch = armv6h
@@ -11,14 +10,17 @@ pkgbase = opam-git
license = GPL
makedepends = git
makedepends = curl
- depends = ocaml
- depends = aspcud
+ depends = bubblewrap
+ depends = ocaml-compiler-libs
+ depends = unzip
+ optdepends = darcs: For downloading packages with darcs
+ optdepends = git: For downloading packages with git
+ optdepends = mercurial: For downloading packages with mercurial
+ optdepends = rsync: For downloading packages with rsync
provides = opam
conflicts = opam
- source = opam-git::git+git://github.com/ocaml/opam
- source = opam-git.install
- md5sums = SKIP
- md5sums = e26e35d3f858c0b5474b778821f9d2e8
+ source = opam-git::git+git://github.com/ocaml/opam.git
+ sha256sums = SKIP
pkgname = opam-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
index 2a4b80bc1d88..1429f638c064 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,39 @@
-# Maintainer: Vincent Bernardoff <vb@luminar.eu.org>
+# Maintainer: Antonin Décimo <antonin dot decimo at gmail dot com>
+# Contributor: Vincent Bernardoff <vb@luminar.eu.org>
# Contributor: Raphaël Proust <raphlalou@gmail.com>
pkgname=opam-git
-pkgver=1.1.0.484.g692cf53
+pkgver=2.1.0.beta2.r165.g1138d481
pkgrel=1
-pkgdesc="OCaml Package Manager"
+pkgdesc='OCaml package manager'
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
-url="https://opam.ocaml.org"
-license=('GPL')
-depends=('ocaml' 'aspcud')
+url='https://opam.ocaml.org/'
+license=(GPL)
+depends=(bubblewrap ocaml-compiler-libs unzip)
makedepends=('git' 'curl')
-provides=('opam')
-conflicts=('opam')
-install='opam-git.install'
-source=("$pkgname"::'git+git://github.com/ocaml/opam' 'opam-git.install')
-md5sums=('SKIP'
- 'e26e35d3f858c0b5474b778821f9d2e8')
+optdepends=(
+ 'darcs: For downloading packages with darcs'
+ 'git: For downloading packages with git'
+ 'mercurial: For downloading packages with mercurial'
+ 'rsync: For downloading packages with rsync'
+)
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("$pkgname"::'git+git://github.com/ocaml/opam.git')
+sha256sums=('SKIP')
pkgver() {
- cd "$pkgname"
- local ver="$(git describe --always)"
- printf "%s" "${ver//-/.}"
+ cd "$pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "$pkgname"
+ cd "$srcdir/${pkgname%-git}"
./configure --prefix=/usr
- make lib-ext -j 1
- make -j 1
+ make lib-ext all
}
package() {
- cd "$pkgname"
+ cd "$srcdir/${pkgname%-git}"
make DESTDIR="$pkgdir" install
}
-
-# vim:set ts=2 sw=2 et:
diff --git a/opam-git.install b/opam-git.install
deleted file mode 100644
index 446f743299ca..000000000000
--- a/opam-git.install
+++ /dev/null
@@ -1,3 +0,0 @@
-post_install() {
- echo "You can now run 'opam init'"
-} \ No newline at end of file