summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortomsik682015-09-20 22:23:27 +0000
committertomsik682015-09-20 22:23:27 +0000
commit28989f98a93ec813d348196be3b901560dafdd0a (patch)
tree7ffab7824003da4fde70b942d8d86b3709e4d3f0
downloadaur-28989f98a93ec813d348196be3b901560dafdd0a.tar.gz
PKGREL 1: Aptana Studio 3.6.1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD43
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..97d4b37275e9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = aptana-studio
+ pkgdesc = Aptana Studio 3.6.1 is code base and complete eclipse-based environment that includes extensive capabilities to build Ruby and Rails, PHP, and Python applications, along with complete HTML, CSS and JavaScript editing.
+ pkgver = 3.6.1
+ pkgrel = 1
+ url = http://www.aptana.com/products/studio3/download.html
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = tar
+ depends = java-runtime
+ source_i686 = https://github.com/aptana/studio3/releases/download/v3.6.1/Aptana_Studio_3_Setup_Linux_x86_3.6.1.zip
+ md5sums_i686 = bf3c1923ea051c29803b6bc2b5d50ff9
+ source_x86_64 = https://github.com/aptana/studio3/releases/download/v3.6.1/Aptana_Studio_3_Setup_Linux_x86_64_3.6.1.zip
+ md5sums_x86_64 = 5df9fa66cd28648e311c1ca662de1508
+
+pkgname = aptana-studio
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..53c59b2d8822
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Tomas Jasek <tomsik68(at)gmail(dot)com>
+
+pkgname="aptana-studio"
+pkgver="3.6.1"
+pkgrel=1
+pkgdesc="Aptana Studio 3.6.1 is code base and complete eclipse-based environment that includes extensive capabilities to build Ruby and Rails, PHP, and Python applications, along with complete HTML, CSS and JavaScript editing. "
+arch=('i686' 'x86_64')
+url="http://www.aptana.com/products/studio3/download.html"
+license=('GPL3')
+groups=()
+depends=('java-runtime')
+makedepends=(tar)
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source_i686=("https://github.com/aptana/studio3/releases/download/v3.6.1/Aptana_Studio_3_Setup_Linux_x86_${pkgver}.zip")
+source_x86_64=("https://github.com/aptana/studio3/releases/download/v3.6.1/Aptana_Studio_3_Setup_Linux_x86_64_${pkgver}.zip")
+md5sums_i686=('bf3c1923ea051c29803b6bc2b5d50ff9')
+md5sums_x86_64=('5df9fa66cd28648e311c1ca662de1508')
+noextract=()
+
+build() {
+ cd $srcdir
+ bsdtar -xf *.zip
+ mkdir -p $srcdir/usr/bin/
+ echo 'exec /usr/lib/aptana/AptanaStudio3' > $srcdir/usr/bin/aptana-studio
+}
+
+package() {
+ cd $srcdir
+ mkdir -p $pkgdir/usr/lib/aptana
+ mv Aptana_Studio_3 $pkgdir/usr/lib/
+ cd $pkgdir/usr/lib/
+ mv Aptana_Studio_3/* aptana
+ rm -rf Aptana_Studio_3
+ mkdir -p $pkgdir/usr/bin/
+ install -m775 $srcdir/usr/bin/aptana-studio $pkgdir/usr/bin/aptana-studio
+}