summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLev Levitsky2022-07-27 15:40:10 +0300
committerLev Levitsky2022-07-27 15:40:10 +0300
commit28b94e7f884b6bd9f2f16dad6cec8b8351a731f2 (patch)
tree573963fda21a85a3d9276f18eecf971a78e3002b
parent08f4048a96f93b8de3f2426d03250674445d33bf (diff)
downloadaur-28b94e7f884b6bd9f2f16dad6cec8b8351a731f2.tar.gz
4.5.4
-rw-r--r--.SRCINFO6
-rw-r--r--CHANGELOG11
-rw-r--r--PKGBUILD4
3 files changed, 15 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5dee6a132ed3..8f6c4e65ab5c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-pyteomics
pkgdesc = A framework for proteomics data analysis.
- pkgver = 4.5.3
+ pkgver = 4.5.4
pkgrel = 1
url = https://pyteomics.readthedocs.io
changelog = CHANGELOG
@@ -16,7 +16,7 @@ pkgbase = python-pyteomics
optdepends = python-dill: needed for multiprocessing when pickle is not enough
optdepends = python-pynumpress: for Numpress support
options = !emptydirs
- source = https://pypi.debian.net/pyteomics/pyteomics-4.5.3-py2.py3-none-any.whl
- sha256sums = 2c61e53ccfb393ed4237f2e11cdaee663d86cbab2688fad5ccc869c52b2b2b6c
+ source = https://pypi.debian.net/pyteomics/pyteomics-4.5.4-py2.py3-none-any.whl
+ sha256sums = ccc1b79b3700b79ec30251e7a751c1bfe306bb30418c8d932ebe6ea9392bb423
pkgname = python-pyteomics
diff --git a/CHANGELOG b/CHANGELOG
index 4ce261301056..46255d91d384 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,3 +1,12 @@
+4.5.4
+-----
+
+ - Fix issue #74.
+ - In :func:`pyteomics.auxiliary.fdr`, raise :exc:`PyteomicsError` instead of :exc:`ZeroDivisionError` when
+ using formula 1 on input without any target PSMs.
+ - Provide more accurate amino acid masses in :py:data:`mass.std_aa_mass`.
+ - Fix SyntaxError in :py:mod:`pyteomics.pylab_aux` on Python 2.7.
+
4.5.3
-----
@@ -47,7 +56,7 @@
- New arguments `keep_nterm_M` and `fix_aa` in :py:func:`pyteomics.fasta.shuffle`
(`#54 <https://github.com/levitsky/pyteomics/pull/54>`_ by Vladimir Gorshkov).
- - Fx for unwanted warnings in :py:func:`pyteomics.auxiliary.file_helpers._check_use_index` when
+ - Fix for unwanted warnings in :py:func:`pyteomics.auxiliary.file_helpers._check_use_index` when
`use_index` is explicitly passed (`#52 <https://github.com/levitsky/pyteomics/issues/52>`_).
- Update the default XML schema for featureXML and fix issues with incorrectly specified data types
diff --git a/PKGBUILD b/PKGBUILD
index fb50ee642a8b..cca7e5381afc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Lev Levitsky <levlev at mail dot ru>
pkgname=python-pyteomics
-pkgver=4.5.3
+pkgver=4.5.4
pkgrel=1
pkgdesc="A framework for proteomics data analysis."
arch=('any')
@@ -16,7 +16,7 @@ optdepends=('python-matplotlib: for pylab_aux module'
'python-pynumpress: for Numpress support')
options=(!emptydirs)
source=("https://pypi.debian.net/pyteomics/pyteomics-${pkgver}-py2.py3-none-any.whl")
-sha256sums=('2c61e53ccfb393ed4237f2e11cdaee663d86cbab2688fad5ccc869c52b2b2b6c')
+sha256sums=('ccc1b79b3700b79ec30251e7a751c1bfe306bb30418c8d932ebe6ea9392bb423')
changelog=CHANGELOG
package() {