summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOwen Trigueros2019-06-11 16:02:46 +0200
committerOwen Trigueros2019-06-11 16:02:46 +0200
commit28ce6aea49dee8c3057c20f8150f6872dec199fb (patch)
tree6eae7c349ecb8933aadb471e3b4bf3cd5bc89653
parent225318c66fb2e054a09aa81dc29e376ea241ae7e (diff)
downloadaur-28ce6aea49dee8c3057c20f8150f6872dec199fb.tar.gz
Fix scripts/ permissions, add conflicts
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD9
-rw-r--r--turtl-server-git.install7
3 files changed, 14 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8416db91878d..ebaabcb3e423 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = turtl-server-git
pkgdesc = The secure, collaborative notebook's server
- pkgver = r209.f37f183
- pkgrel = 2
+ pkgver = r211.babccca
+ pkgrel = 1
url = https://turtlapp.com/
install = turtl-server-git.install
arch = any
@@ -10,12 +10,13 @@ pkgbase = turtl-server-git
makedepends = npm
depends = nodejs
depends = postgresql
+ conflicts = turtl-server
source = turtl-server-git::git+https://github.com/turtl/server.git
source = turtl-server-git.install
source = turtl.service
source = turtl.sysusers
md5sums = SKIP
- md5sums = 2277c97e9f9ea821b35f5f4215e5ff9b
+ md5sums = 95e7cdde22d846c34334b7f61aa0980c
md5sums = ef593935d035ae7df448dbb18aaed70f
md5sums = c6727740e7165fa825bc011ec5f50f78
diff --git a/PKGBUILD b/PKGBUILD
index 7080ea900f79..0c0d7dc16349 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,15 @@
# Maintainer: Owen Trigueros <owentrigueros@gmail.com>
pkgname=turtl-server-git
-pkgver=r209.f37f183
-pkgrel=2
+pkgver=r211.babccca
+pkgrel=1
pkgdesc="The secure, collaborative notebook's server"
arch=('any')
url="https://turtlapp.com/"
license=('AGPL')
depends=('nodejs' 'postgresql')
makedepends=('git' 'npm')
+conflicts=('turtl-server')
install=$pkgname.install
source=("$pkgname::git+https://github.com/turtl/server.git"
"turtl-server-git.install"
@@ -16,7 +17,7 @@ source=("$pkgname::git+https://github.com/turtl/server.git"
"turtl.sysusers")
md5sums=('SKIP'
- '2277c97e9f9ea821b35f5f4215e5ff9b'
+ '95e7cdde22d846c34334b7f61aa0980c'
'ef593935d035ae7df448dbb18aaed70f'
'c6727740e7165fa825bc011ec5f50f78')
@@ -42,7 +43,7 @@ package() {
find controllers/ -type f -exec install -Dm644 {} "$pkgdir"/usr/share/webapps/turtl/{} \;
find helpers/ -type f -exec install -Dm644 {} "$pkgdir"/usr/share/webapps/turtl/{} \;
find models/ -type f -exec install -Dm644 {} "$pkgdir"/usr/share/webapps/turtl/{} \;
- find scripts/ -type f -exec install -Dm644 {} "$pkgdir"/usr/share/webapps/turtl/{} \;
+ find scripts/ -type f -exec install -Dm755 {} "$pkgdir"/usr/share/webapps/turtl/{} \;
find tools/ -type f -exec install -Dm644 {} "$pkgdir"/usr/share/webapps/turtl/{} \;
find node_modules/ -type f -exec install -Dm644 {} "$pkgdir"/usr/share/webapps/turtl/{} \;
install -Dm644 server.js "$pkgdir"/usr/share/webapps/turtl/server.js
diff --git a/turtl-server-git.install b/turtl-server-git.install
index e9a25341585a..a213bfd76d64 100644
--- a/turtl-server-git.install
+++ b/turtl-server-git.install
@@ -3,10 +3,13 @@
post_install() {
chown -R turtl:turtl /var/lib/turtl
echo ":: Turtle needs a dedicated PostgreSQL user/db set up for it."
- echo " Once it's set up, edit /var/www/turtl/server/config/config.yaml"
+ echo " Once it's set up, edit /usr/share/webapps/turtl/config/config.yaml"
echo " to make 'connstr' match your user/db."
echo " e.g.: postgres://turtl:strongpassword@127.0.0.1:5432/turtl"
echo
+ echo " Visit https://wiki.archlinux.org/index.php/PostgreSQL"
+ echo " to know how to install and configure PostgreSQL"
+ echo
echo ":: Take a look into 'uploads' and 's3' in config.yaml,"
echo " you may need to modify them to match your needs."
echo
@@ -14,7 +17,7 @@ post_install() {
echo " to any long string you want."
echo
echo ":: Then, initialize the database"
- echo " cd /var/www/turtl/server"
+ echo " cd /usr/share/webapps/turtl"
echo " ./scripts/init-db.sh"
echo
echo ":: Finnaly, start the server: systemctl start turtl.service"