summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJP-Ellis2018-08-13 19:29:53 +0200
committerJP-Ellis2018-08-13 19:29:53 +0200
commit28d82d5f782590078e95ea9dd8816080306a975f (patch)
tree44a397c296e581f0b8d0acff7ecfe380fafde84c
downloadaur-28d82d5f782590078e95ea9dd8816080306a975f.tar.gz
Initial commit
Signed-off-by: JP-Ellis <josh@jpellis.me>
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD27
3 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b9ab4fceb291
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by mksrcinfo v8
+# Mon Aug 13 17:29:30 UTC 2018
+pkgbase = python-pyparser
+ pkgdesc = pyparser is a collection of classes to make it easier to parse text data in a pythonic way.
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://pypi.org/project/pyparser/
+ arch = any
+ license = GPL
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/p/pyparser/pyparser-1.0.tar.gz
+ sha256sums = d1b76e2dabdd2952cadfd545229cc144afee6130bf171a031d5bf53f11b912f5
+
+pkgname = python-pyparser
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..335ec9573de5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..93c0487a9ec7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: JP-Ellis <josh@jpellis.me>
+pkgname=python-pyparser
+_name=${pkgname#python-}
+pkgver=1.0
+pkgrel=1
+pkgdesc="pyparser is a collection of classes to make it easier to parse text data in a pythonic way."
+arch=('any')
+url="https://pypi.org/project/pyparser/"
+license=('GPL')
+depends=('python')
+optdepends=()
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha256sums=('d1b76e2dabdd2952cadfd545229cc144afee6130bf171a031d5bf53f11b912f5')
+noextract=()
+
+build() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ sed -i 's/parse==1.6.5/parse>=1.6.5/' requirements.txt
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}
+
+# vim:set ts=2 sw=2 et: