summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2022-01-05 11:12:57 +0800
committerUniversebenzene2022-01-05 11:12:57 +0800
commit2908b97272b0c8916e30dcee56b8ea24c94346ef (patch)
treeeeaae9ebe968593c85a43c19e9bb0e9977db2396
parent17b97df844a85a67c61058c962769be482cdb4b2 (diff)
downloadaur-2908b97272b0c8916e30dcee56b8ea24c94346ef.tar.gz
Update to version 1.2.22
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 999a87fba713..e38fccd2207c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-spherical_geometry
pkgdesc = Python based tools for spherical geometry
- pkgver = 1.2.21
+ pkgver = 1.2.22
pkgrel = 1
url = http://www.stsci.edu/resources/software_hardware/stsci_python
arch = i686
@@ -13,10 +13,10 @@ pkgbase = python-spherical_geometry
makedepends = qd>=2.3.7
makedepends = python-sphinx-automodapi
makedepends = python-numpydoc
- source = https://files.pythonhosted.org/packages/source/s/spherical_geometry/spherical_geometry-1.2.21.tar.gz
+ source = https://files.pythonhosted.org/packages/source/s/spherical_geometry/spherical_geometry-1.2.22.tar.gz
source = fix_typo.patch
source = fix_doc_warning.patch
- md5sums = 76fc6423af7cdd99bf98de58820b9c4e
+ md5sums = 8537874297c128da8933416284356e68
md5sums = 376f76ebdf3c52048a113c386c091210
md5sums = fed5395d45a2275ccd5e0d63956ecddf
diff --git a/PKGBUILD b/PKGBUILD
index f07b4c932182..0032dbf40f75 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgbase=python-spherical_geometry
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}" "python-${_pyname}-doc")
-pkgver=1.2.21
+pkgver=1.2.22
pkgrel=1
pkgdesc="Python based tools for spherical geometry"
arch=('i686' 'x86_64')
@@ -13,7 +13,7 @@ checkdepends=('python-pytest' 'python-astropy')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz"
'fix_typo.patch'
'fix_doc_warning.patch')
-md5sums=('76fc6423af7cdd99bf98de58820b9c4e'
+md5sums=('8537874297c128da8933416284356e68'
'376f76ebdf3c52048a113c386c091210'
'fed5395d45a2275ccd5e0d63956ecddf')
@@ -40,7 +40,7 @@ check() {
export _pyver=$(python -c 'import sys; print("%d.%d" % sys.version_info[:2])')
cp "build/lib.linux-${CARCH}-${_pyver}/${_pyname}/math_util.cpython-${_pyver/./}-${CARCH}-linux-gnu.so" \
"${_pyname}"
- PYTHONPATH="build/lib.linux-${CARCH}-${_pyver}" pytest \
+ pytest \
--deselect=spherical_geometry/tests/test_union.py::test_difficult_unions || warning "Tests failed"
}