summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Grzywna2023-02-06 10:19:40 +0100
committerSebastian Grzywna2023-02-06 10:31:11 +0100
commit293822e01579e313df76fa7f6ac1028fb980d296 (patch)
treef8f865a1a415770c573ee3ca838c97ed9c597139
parent3ce15f213c7b53b7396241630a94930c476b7bc3 (diff)
downloadaur-293822e01579e313df76fa7f6ac1028fb980d296.tar.gz
Revert c558b36 check() removal
check() can be disabled in makepkg.conf and via makepkg --nocheck
-rw-r--r--PKGBUILD21
1 files changed, 11 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bb15702dab73..88df61639199 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ url="https://metacpan.org/dist/Wx"
license=('GPL' 'PerlArtistic')
depends=('perl-alien-wxwidgets' 'perl-extutils-xspp' 'wxgtk3')
makedepends=('perl-module-build')
-#checkdepends=('xorg-server-xvfb')
+checkdepends=('xorg-server-xvfb')
options=('!emptydirs')
source=("https://cpan.metacpan.org/authors/id/M/MD/MDOOTSON/Wx-$pkgver.tar.gz"
'https://src.fedoraproject.org/rpms/perl-Wx/raw/rawhide/f/Wx-0.9932-Undefine-BOM_UTF8.patch'
@@ -53,15 +53,16 @@ build(){
make
}
-#check(){
-# cd "Wx-$pkgver"
-# if [[ -z "$DISPLAY" || -x /usr/bin/xvfb-run ]]; then
-## warning 'Empty $DISPLAY - falling back to xvfb-run (xorg-server-xvfb)'
-# xvfb-run -a -s "+extension GLX -screen 0 1280x1024x24" make test
-# else
-# make test
-# fi
-#}
+# Use makepkg --nocheck to disable check()
+check(){
+ cd "Wx-$pkgver"
+ if [[ -z "$DISPLAY" || -x /usr/bin/xvfb-run ]]; then
+# warning 'Empty $DISPLAY - falling back to xvfb-run (xorg-server-xvfb)'
+ xvfb-run -a -s "+extension GLX -screen 0 1280x1024x24" make test
+ else
+ make test
+ fi
+}
package(){
cd "Wx-$pkgver"