summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2023-10-01 10:48:16 -0300
committerDaniel Bermond2023-10-01 10:48:16 -0300
commit29994d12bd859c68a1c3da7009781a1190105fb0 (patch)
treeaae17fa56e92019491dce2f2d19032496cfa33f6
parent0989287d3b794cacd93a555587e53f58104a2293 (diff)
downloadaur-29994d12bd859c68a1c3da7009781a1190105fb0.tar.gz
Update ffnvcodec-headers dependency and svt patches
ffmpeg git master currently requires ffnvcodec-headers git master. This is not the first time it happens, so maybe it's better to keep it for the long run to avoid breakages in building.
-rw-r--r--.SRCINFO8
-rw-r--r--040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch4
-rw-r--r--060-ffmpeg-fix-segfault-with-avisynthplus.patch2
-rw-r--r--PKGBUILD8
4 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5a8f8b15ec85..c7cf054f6d15 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ffmpeg-git
pkgdesc = Complete solution to record, convert and stream audio and video (git version)
- pkgver = 6.1.r111232.g468615f204
+ pkgver = 6.1.r112250.g6f7bf64dbc
pkgrel = 1
url = https://www.ffmpeg.org/
arch = x86_64
@@ -8,7 +8,7 @@ pkgbase = ffmpeg-git
makedepends = amf-headers
makedepends = avisynthplus
makedepends = clang
- makedepends = ffnvcodec-headers
+ makedepends = ffnvcodec-headers-git
makedepends = git
makedepends = ladspa
makedepends = mesa
@@ -94,7 +94,7 @@ pkgbase = ffmpeg-git
source = 040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch
source = 060-ffmpeg-fix-segfault-with-avisynthplus.patch
sha256sums = SKIP
- sha256sums = d1ad786df86354d218a70b306a50961736c0a6e2d2716bf8de3db31d79957df9
- sha256sums = bf563193f450ece58a93db6840c0db33875df945fa81477b9b02fb209d3bf57a
+ sha256sums = 9b94b90a33dc8ac9693d72c825e9c444df914428fce7cca61117146ee8f8c07b
+ sha256sums = 0e277c0d5e33612ca7a11025958133b17bfbe23168b0aee5bd07f674f6fd7440
pkgname = ffmpeg-git
diff --git a/040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch b/040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch
index b6eb1d7394b5..3f4605d968ab 100644
--- a/040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch
+++ b/040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch
@@ -1,6 +1,6 @@
--- a/libavformat/avformat.h
+++ b/libavformat/avformat.h
-@@ -1019,6 +1019,10 @@ attribute_deprecated
+@@ -1020,6 +1020,10 @@ attribute_deprecated
int64_t av_stream_get_end_pts(const AVStream *st);
#endif
@@ -13,7 +13,7 @@
/**
--- a/libavformat/utils.c
+++ b/libavformat/utils.c
-@@ -55,6 +55,13 @@ int ff_unlock_avformat(void)
+@@ -56,6 +56,13 @@ int ff_unlock_avformat(void)
return ff_mutex_unlock(&avformat_mutex) ? -1 : 0;
}
diff --git a/060-ffmpeg-fix-segfault-with-avisynthplus.patch b/060-ffmpeg-fix-segfault-with-avisynthplus.patch
index dd58e840eec1..9e2ddb399c9e 100644
--- a/060-ffmpeg-fix-segfault-with-avisynthplus.patch
+++ b/060-ffmpeg-fix-segfault-with-avisynthplus.patch
@@ -1,6 +1,6 @@
--- a/libavformat/avisynth.c
+++ b/libavformat/avisynth.c
-@@ -141,7 +141,7 @@ static av_cold void avisynth_atexit_handler(void);
+@@ -142,7 +142,7 @@ static av_cold void avisynth_atexit_handler(void);
static av_cold int avisynth_load_library(void)
{
diff --git a/PKGBUILD b/PKGBUILD
index d653c80329d4..5012097fb579 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: DrZaius <lou at fakeoutdoorsman.com>
pkgname=ffmpeg-git
-pkgver=6.1.r111232.g468615f204
+pkgver=6.1.r112250.g6f7bf64dbc
pkgrel=1
pkgdesc='Complete solution to record, convert and stream audio and video (git version)'
arch=('x86_64')
@@ -77,7 +77,7 @@ makedepends=(
amf-headers
avisynthplus
clang
- ffnvcodec-headers
+ ffnvcodec-headers-git
git
ladspa
mesa
@@ -97,8 +97,8 @@ source=('git+https://git.ffmpeg.org/ffmpeg.git'
'040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch'
'060-ffmpeg-fix-segfault-with-avisynthplus.patch')
sha256sums=('SKIP'
- 'd1ad786df86354d218a70b306a50961736c0a6e2d2716bf8de3db31d79957df9'
- 'bf563193f450ece58a93db6840c0db33875df945fa81477b9b02fb209d3bf57a')
+ '9b94b90a33dc8ac9693d72c825e9c444df914428fce7cca61117146ee8f8c07b'
+ '0e277c0d5e33612ca7a11025958133b17bfbe23168b0aee5bd07f674f6fd7440')
prepare() {
patch -d ffmpeg -Np1 -i "${srcdir}/040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch"