summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2022-03-15 23:18:03 +0100
committerNarrat2022-03-15 23:18:03 +0100
commit29a4c518745ee805c58944d4d6da5f1224cab364 (patch)
tree0c4a0c9b9dea0b595fe82bd359d424668d1a06f9
parentfea0e82f2d0ccebd2c73969086cc8e25339fd5f3 (diff)
downloadaur-29a4c518745ee805c58944d4d6da5f1224cab364.tar.gz
labwc-git: Adjustments in regards to meson guidelines
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 5 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4b84f625dfef..a1766858ce22 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = labwc-git
pkgdesc = stacking wayland compositor with look and feel from openbox (git version)
- pkgver = 0.5.0.r1.g68d897e
+ pkgver = 0.5.0.r76.g5fd5024
pkgrel = 1
url = https://github.com/labwc/labwc
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index e944e91c9365..4ad9136545b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=labwc
pkgname=labwc-git
-pkgver=0.5.0.r1.g68d897e
+pkgver=0.5.0.r76.g5fd5024
pkgrel=1
pkgdesc='stacking wayland compositor with look and feel from openbox (git version)'
url="https://github.com/labwc/labwc"
@@ -23,12 +23,10 @@ pkgver() {
}
build() {
- cd "$_pkgname"
- arch-meson -Dman-pages=enabled ../build
- ninja -v -C ../build
+ arch-meson -Dman-pages=enabled "$_pkgname" build
+ meson compile -C build
}
package() {
- cd "$_pkgname"
- DESTDIR="${pkgdir}" meson install -C ../build
+ meson install -C build --destdir "$pkgdir"
}