summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosip Ponjavic2019-07-14 16:28:43 +0200
committerJosip Ponjavic2019-07-14 16:28:43 +0200
commit29a9d25a956550f49cab6eef431f620eb42f7b0c (patch)
tree7543792e818af46917dfc6ecce24be09a5e664f5
parent47c630e14d0840fcb41107449c8acf850797b9e3 (diff)
downloadaur-29a9d25a956550f49cab6eef431f620eb42f7b0c.tar.gz
upgpkg: 19.06.g2abe6e7f-1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 22e5a3299005..d2bec4155dfc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = mpc-qt
pkgdesc = A clone of Media Player Classic reimplimented in Qt.
- pkgver = 18.08
+ pkgver = 19.06.g2abe6e7f
pkgrel = 1
- url = https://github.com/cmdrkotori/mpc-qt
+ url = https://gitlab.com/mpc-qt/mpc-qt
arch = x86_64
license = GPL2
makedepends = git
@@ -12,8 +12,8 @@ pkgbase = mpc-qt
optdepends = libva-vdpau-driver: backend for Nvidia and AMD cards
optdepends = libva-intel-driver: backend for Intel cards
optdepends = udisks2: to detect available discs
- source = mpc-qt-18.08.tar.gz::https://github.com/cmdrkotori/mpc-qt/archive/v18.08.tar.gz
- sha256sums = c58fd90926773c9da8bdfc1a8e4dba0b95cbc58cee6db9981e8de94fd9534406
+ source = mpc-qt-19.06.g2abe6e7f.tar.bz2::https://gitlab.com/mpc-qt/mpc-qt/-/archive/2abe6e7fc643068d50522468fe75d614861555ad/mpc-qt-2abe6e7fc643068d50522468fe75d614861555ad.tar.bz2
+ sha256sums = 2d1b1dfbd73123a93461ee98176d5b405c63b2d89021566ff025dda9c016998c
pkgname = mpc-qt
diff --git a/PKGBUILD b/PKGBUILD
index 57c2fd18e8d4..c594716989a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,11 @@
# Contributor:
pkgname=mpc-qt
-pkgver=18.08
+pkgver=19.06.g2abe6e7f
pkgrel=1
+_commit=2abe6e7fc643068d50522468fe75d614861555ad
pkgdesc='A clone of Media Player Classic reimplimented in Qt.'
-url='https://github.com/cmdrkotori/mpc-qt'
+url='https://gitlab.com/mpc-qt/mpc-qt'
arch=('x86_64')
license=('GPL2')
depends=('mpv' 'qt5-x11extras')
@@ -13,11 +14,11 @@ makedepends=('git' 'qt5-tools')
optdepends=('libva-vdpau-driver: backend for Nvidia and AMD cards'
'libva-intel-driver: backend for Intel cards'
'udisks2: to detect available discs')
-source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
-sha256sums=('c58fd90926773c9da8bdfc1a8e4dba0b95cbc58cee6db9981e8de94fd9534406')
+source=("${pkgname}-${pkgver}.tar.bz2::${url}/-/archive/${_commit}/${pkgname}-${_commit}.tar.bz2")
+sha256sums=('2d1b1dfbd73123a93461ee98176d5b405c63b2d89021566ff025dda9c016998c')
build() {
- cd "${pkgname}-${pkgver}"
+ cd "${pkgname}-${_commit}"
qmake-qt5 PREFIX=/usr mpc-qt.pro \
QMAKE_CFLAGS_RELEASE="${CFLAGS}" \
QMAKE_CXXFLAGS_RELEASE="${CXXFLAGS}" \
@@ -26,5 +27,5 @@ build() {
}
package() {
- make -C "${pkgname}-${pkgver}" INSTALL_ROOT="${pkgdir}" install
+ make -C "${pkgname}-${_commit}" INSTALL_ROOT="${pkgdir}" install
}