summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYuval Adam2019-07-10 10:06:43 +0300
committerYuval Adam2019-07-10 10:06:43 +0300
commit29aa030c8ea1bb5f11fbca98125c82590f44e4d4 (patch)
tree9b9026a80986600ac2d3d2bcc3e281be1768ae3d
downloadaur-29aa030c8ea1bb5f11fbca98125c82590f44e4d4.tar.gz
Initial pygreat-git package
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e9c79df09903
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = pygreat-git
+ pkgdesc = A library to help you do Great things
+ pkgver = v2019.5.1.dev0.6.g1e982b2
+ pkgrel = 1
+ url = https://github.com/yuvadm/libgreat
+ arch = any
+ license = BSD
+ depends = python-pyusb
+ depends = python-future
+ provides = pygreat
+ source = git+https://github.com/yuvadm/libgreat
+ sha1sums = SKIP
+
+pkgname = pygreat-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e68aec6e0fd6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Yuval Adam <aur at yuv dot al> PGP-Key: 55E36E28535222E2A2062848B75B5FC2FA1AFE15
+
+pkgname=pygreat-git
+pkgver=v2019.5.1.dev0.6.g1e982b2
+pkgrel=1
+pkgdesc="A library to help you do Great things"
+arch=('any')
+url="https://github.com/greatscottgadgets/libgreat"
+license=(BSD)
+depends=('python-pyusb' 'python-future')
+provides=('pygreat')
+source=("git+${url}")
+sha1sums=('SKIP')
+_gitname=libgreat
+
+pkgver() {
+ cd $_gitname
+ echo $(git describe --always | sed 's/-/./g')
+}
+
+package() {
+ cd "${_gitname}/host"
+ python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: