summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGordian Edenhofer2015-05-23 14:10:08 +0200
committerGordian Edenhofer2015-05-23 14:10:08 +0200
commit29c307f267cd5449c0549f28b7d16a4ea3b6aeb1 (patch)
treec3dfb68ee8afdb89a1bcfbb4a185773619b33b83
downloadaur-29c307f267cd5449c0549f28b7d16a4ea3b6aeb1.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--CHANGELOG8
-rw-r--r--PKGBUILD30
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d2e9246942d8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by makepkg 4.2.1
+# Sat May 23 12:03:59 UTC 2015
+pkgbase = gtk-theme-iris-light-git
+ pkgdesc = A flat theme that uses varying shades and tones to create distinction and a modern experience. It supports Gtk 3.10, Gtk 3.12 and Gtk 2 (using the Murrine engine).
+ pkgver = 103.a416581
+ pkgrel = 1
+ url = http://thevirtualdragon.deviantart.com/art/Iris-Light-Beta-428948909
+ changelog = CHANGELOG
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = gtk3
+ depends = gtk-engine-murrine
+ provides = gtk-theme-iris-light
+ source = iris-light::git+https://github.com/xyl0n/iris-light.git
+ sha256sums = SKIP
+
+pkgname = gtk-theme-iris-light-git
+
diff --git a/CHANGELOG b/CHANGELOG
new file mode 100644
index 000000000000..4bd7bbfd6d10
--- /dev/null
+++ b/CHANGELOG
@@ -0,0 +1,8 @@
+2015.02.11: Fixed moar bugs! Gtk 3.14 now supported.
+2014.09.04: Fixed many bugs in Gtk 2 treeview, add Nemo theming, fixed Popover issues and added Budgie Desktop theming. Slight changed in menu colours.
+2014.08.04: Fixed bugs with Java app menus and distortion of insensitive menu items in Gtk2.
+2014.06.23: Hacky support for new aura-based Chrome.
+2014.05.10: Updated to Gtk 3.12 and added support for new Unity theming.
+2014.03.16: Fixed bugs in Chrome as well as other tweaks.
+2014.02.17: Tweaks and experimental Unity CSD support for Ubuntu 14.04
+2014.02.02: Fixed bugs with Firefox and tweaked Terminal.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7105f3aa6e35
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Gordian Edenhofer <gordian.edenhofer[at]yahoo[dot]de>
+# Contributor: Gustavo Castro <gustawho[at]gmail[dot]com>
+# Submitter: acrox999 <acrox999[at]gmail[dot]com>
+
+pkgname=gtk-theme-iris-light-git
+_pkgname=iris-light
+pkgver=103.a416581
+pkgrel=1
+pkgdesc="A flat theme that uses varying shades and tones to create distinction and a modern experience. It supports Gtk 3.10, Gtk 3.12 and Gtk 2 (using the Murrine engine)."
+arch=('any')
+url="http://thevirtualdragon.deviantart.com/art/Iris-Light-Beta-428948909"
+license=('GPL3')
+depends=('gtk3' 'gtk-engine-murrine')
+makedepends=('git')
+provides=('gtk-theme-iris-light')
+changelog=('CHANGELOG')
+source=(${_pkgname}::'git+https://github.com/xyl0n/iris-light.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ install -dm755 "${pkgdir}/usr/share/themes/${_pkgname}"
+ rm -rf {.git,CREDITS,LICENSE,README,README.md}
+ cp -dpr --no-preserve=ownership . "${pkgdir}/usr/share/themes/${_pkgname}/"
+}