summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkmille2022-02-09 12:38:07 +0100
committerkmille2022-02-09 12:38:07 +0100
commit2a03d07d32dde1c42a23c8b12eeff03513564d80 (patch)
tree4ce4b6222040d0653cc13acb8d0608fa2b678768
parentbedd6b36e9b5a543b30a1dacb27677efc98d6f74 (diff)
downloadaur-2a03d07d32dde1c42a23c8b12eeff03513564d80.tar.gz
Change upstream repo, fix grub2.06 issue, hook grub-install
changes: https://github.com/kmille/cryptboot/compare/v1.1.0..v1.2.0 discussion: https://github.com/xmikos/cryptboot/issues/7
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 63896b2bee32..87ed64ace068 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Tue Sep 6 13:10:25 UTC 2016
pkgbase = cryptboot
pkgdesc = Encrypted boot partition manager with UEFI Secure Boot support
- pkgver = 1.1.0
+ pkgver = 1.2.0
pkgrel = 1
url = https://github.com/xmikos/cryptboot
arch = any
@@ -12,8 +10,7 @@ pkgbase = cryptboot
depends = efibootmgr
depends = efitools
depends = sbsigntools
- source = https://github.com/xmikos/cryptboot/archive/v1.1.0.tar.gz
- sha256sums = f3227cbe2847d389b6c340a73e26f6859c18f6eef662a7822b5582cfee6d5538
+ source = https://github.com/kmille/cryptboot/archive/refs/tags/v1.2.0.tar.gz
+ sha256sums = 53863e54be9bcd6bd47ad05b5c0afbcaae139d590106ef098da275adb86f46e6
pkgname = cryptboot
-
diff --git a/PKGBUILD b/PKGBUILD
index d5a67411a7d1..d5858d108b26 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,21 @@
+# Maintainer: kmille <github@androidloves.me>
# Maintainer: Michal Krenek (Mikos) <m.krenek@gmail.com>
pkgname=cryptboot
-pkgver=1.1.0
+pkgver=1.2.0
pkgrel=1
pkgdesc="Encrypted boot partition manager with UEFI Secure Boot support"
arch=('any')
url="https://github.com/xmikos/cryptboot"
license=('GPL3')
depends=('cryptsetup' 'grub' 'efibootmgr' 'efitools' 'sbsigntools')
-source=(https://github.com/xmikos/cryptboot/archive/v$pkgver.tar.gz)
-sha256sums=('f3227cbe2847d389b6c340a73e26f6859c18f6eef662a7822b5582cfee6d5538')
+source=(https://github.com/kmille/cryptboot/archive/refs/tags/v$pkgver.tar.gz)
+sha256sums=('53863e54be9bcd6bd47ad05b5c0afbcaae139d590106ef098da275adb86f46e6')
package() {
cd "$srcdir/$pkgname-$pkgver"
install -Dm755 cryptboot "$pkgdir/usr/bin/cryptboot"
install -Dm755 cryptboot-efikeys "$pkgdir/usr/bin/cryptboot-efikeys"
+ install -Dm755 grub-install "$pkgdir/usr/local/bin/grub-install"
install -Dm644 cryptboot.conf "$pkgdir/etc/cryptboot.conf"
}