summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2024-01-15 20:14:31 -0700
committerMark Wagie2024-01-15 20:14:31 -0700
commit2a09c1fb60edc4a682b621fc6cb7284ef3514f14 (patch)
tree52e0c747f801093e86c19009e9fb0604da9c12c1
parent8e1011ee70cae34d52f7f487c15788e0c9e60da6 (diff)
downloadaur-2a09c1fb60edc4a682b621fc6cb7284ef3514f14.tar.gz
Fix metadata.xml
- Remove wine from checkdepends - Use SPDX license identifier
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD20
2 files changed, 19 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0bf658a94402..302c725ea466 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = lutris-git
pkgdesc = Open Gaming Platform
- pkgver = 0.5.14.r27.g1f1d554df
+ pkgver = 0.5.16.r0.g85871982b
pkgrel = 1
- url = https://lutris.net/
+ url = https://lutris.net
arch = any
- license = GPL3
+ license = GPL-3.0-or-later
checkdepends = appstream-glib
checkdepends = fluidsynth
checkdepends = pciutils
checkdepends = python-nose-cover3
checkdepends = vulkan-tools
- checkdepends = wine
checkdepends = xorg-server-xvfb
checkdepends = xterm
makedepends = git
@@ -64,6 +63,8 @@ pkgbase = lutris-git
provides = lutris
conflicts = lutris
source = git+https://github.com/lutris/lutris.git
+ source = https://github.com/lutris/lutris/pull/5241.patch
sha256sums = SKIP
+ sha256sums = 8d1c5ef9cb317154ece98ceceaa1babe20f0e67f9794f25832af2e7bdb347355
pkgname = lutris-git
diff --git a/PKGBUILD b/PKGBUILD
index 8bf454047189..bdff62ea63b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,12 +5,12 @@
# Contributor: Frederik “Freso” S. Olesen <freso.dk@gmail.com>
# Contributor: Maxime Gauduin <alucryd@archlinux.org>
pkgname=lutris-git
-pkgver=0.5.14.r27.g1f1d554df
+pkgver=0.5.16.r0.g85871982b
pkgrel=1
pkgdesc='Open Gaming Platform'
arch=('any')
-url='https://lutris.net/'
-license=('GPL3')
+url="https://lutris.net"
+license=('GPL-3.0-or-later')
depends=(
'cabextract'
'curl'
@@ -44,7 +44,6 @@ checkdepends=(
'pciutils'
'python-nose-cover3'
'vulkan-tools'
- 'wine'
'xorg-server-xvfb'
'xterm'
)
@@ -73,14 +72,23 @@ optdepends=(
'xorg-xgamma: Restore gamma on game exit')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=('git+https://github.com/lutris/lutris.git')
-sha256sums=('SKIP')
+source=('git+https://github.com/lutris/lutris.git'
+ 'https://github.com/lutris/lutris/pull/5241.patch')
+sha256sums=('SKIP'
+ '8d1c5ef9cb317154ece98ceceaa1babe20f0e67f9794f25832af2e7bdb347355')
pkgver() {
cd "${pkgname%-git}"
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd "${pkgname%-git}"
+
+ # Fix metainfo.xml
+ patch -Np1 -i ../5241.patch
+}
+
build() {
arch-meson "${pkgname%-git}" build
meson compile -C build