summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKrystian Chachuła2019-09-18 23:07:07 +0200
committerKrystian Chachuła2019-09-18 23:07:07 +0200
commit2a51fc6202d8b316381a62f41246a053676a235a (patch)
tree977191ec3b7d77d2bc383d9572691c80ef858f7e
parentfa08c8c6679cf931483db423f738804ffc9fd36a (diff)
downloadaur-2a51fc6202d8b316381a62f41246a053676a235a.tar.gz
bump version
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD29
2 files changed, 18 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 22d7027eacca..a33a76990dc9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dex-git
- pkgdesc = A program to execute DesktopEntry files of type Application, primarily for window managers that do not implement the Freedesktop autostart specification
- pkgver = 62.2d158ca
+ pkgdesc = Program to generate and execute DesktopEntry files of type Application
+ pkgver = 83.864be05
pkgrel = 1
url = https://github.com/jceb/dex
arch = any
@@ -11,7 +11,7 @@ pkgbase = dex-git
provides = dex
conflicts = dex
source = git+https://github.com/jceb/dex.git
- sha256sums = SKIP
+ md5sums = SKIP
pkgname = dex-git
diff --git a/PKGBUILD b/PKGBUILD
index f5b6570ca600..e8b4506b6a62 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,33 @@
-# Maintainer: mutantmonkey <aur@mutantmonkey.in>
+# Maintainer: Krystian Chachuła <krystiancha@gmail.com>
+
pkgname=dex-git
-pkgver=62.2d158ca
+pkgver=83.864be05
pkgrel=1
-pkgdesc="A program to execute DesktopEntry files of type Application, primarily for window managers that do not implement the Freedesktop autostart specification"
-url="https://github.com/jceb/dex"
+
+pkgdesc='Program to generate and execute DesktopEntry files of type Application'
+url='https://github.com/jceb/dex'
arch=('any')
license=('GPL2')
+
depends=('python')
makedepends=('git' 'python-sphinx')
+
provides=('dex')
conflicts=('dex')
-source=('git+https://github.com/jceb/dex.git')
-sha256sums=('SKIP')
+
+source=("git+https://github.com/jceb/dex.git")
+
+md5sums=('SKIP')
pkgver() {
cd "$srcdir/dex"
echo $(git rev-list --count master).$(git rev-parse --short master)
}
-build() {
- cd "$srcdir/dex"
- make PREFIX=/usr
-}
-
package() {
- cd "$srcdir/dex"
- make DESTDIR="$pkgdir/" PREFIX=/usr install
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd dex
+ make install PREFIX=/usr MANPREFIX=/usr/share/man DESTDIR="$pkgdir"
+ rm "$pkgdir/usr/share/doc/dex/LICENSE"
}
# vim:set ts=2 sw=2 et: