summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrzej Giniewicz2015-07-07 19:37:23 +0200
committerAndrzej Giniewicz2015-07-07 19:37:23 +0200
commit2a55866245a7dc29f15f45bd215e20908681f262 (patch)
treee8a6996cf4b079e9b4a9ca80e679c538d9af4fd7
downloadaur-2a55866245a7dc29f15f45bd215e20908681f262.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--LICENSE35
-rw-r--r--PKGBUILD44
-rw-r--r--product.pngbin0 -> 42674 bytes
-rw-r--r--scala-ide.desktop8
5 files changed, 106 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..da996ac623c1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = eclipse-scala-ide
+ pkgdesc = Scala IDE for Eclipse
+ pkgver = 4.1.0
+ pkgrel = 1
+ url = http://www.scala-ide.org/
+ arch = any
+ license = custom
+ depends = eclipse>=4.4
+ source = eclipse-scala-ide-4.1.0.zip::http://download.scala-ide.org/sdk/lithium/e44/scala211/stable/update-site.zip
+ source = LICENSE
+ source = scala-ide.desktop
+ source = product.png
+ md5sums = 62940db3f4802d5a85b07e2be8dd9b43
+ md5sums = 58b225f304aaf42c8b8738894a10cb96
+ md5sums = 205ac79eeebb9cc43f9a0c836e60cf82
+ md5sums = c95b1920928f10d2c982afd7f5827a2c
+
+pkgname = eclipse-scala-ide
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..38d16361bd23
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,35 @@
+SCALA LICENSE
+
+Copyright (c) 2002-2011 EPFL, Lausanne, unless otherwise specified.
+All rights reserved.
+
+This software was developed by the Programming Methods Laboratory of the
+Swiss Federal Institute of Technology (EPFL), Lausanne, Switzerland.
+
+Permission to use, copy, modify, and distribute this software in source
+or binary form for any purpose with or without fee is hereby granted,
+provided that the following conditions are met:
+
+ 1. Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+
+ 2. Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+
+ 3. Neither the name of the EPFL nor the names of its contributors
+ may be used to endorse or promote products derived from this
+ software without specific prior written permission.
+
+
+THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS ``AS IS'' AND
+ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+ARE DISCLAIMED. IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE
+FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
+SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
+CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
+OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..de1702dde7cd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+#Maintainer: Andrzej Giniewicz <gginiu@gmail.com>
+#Contributor: Kristof Jozsa <kjozsa@fsdev.hu>
+
+pkgname=eclipse-scala-ide
+pkgver=4.1.0
+pkgrel=1
+pkgdesc="Scala IDE for Eclipse"
+arch=('any')
+url="http://www.scala-ide.org/"
+license=('custom')
+depends=('eclipse>=4.4')
+
+source=($pkgname-$pkgver.zip::"http://download.scala-ide.org/sdk/lithium/e44/scala211/stable/update-site.zip"
+ "LICENSE" "scala-ide.desktop" "product.png"
+)
+md5sums=('62940db3f4802d5a85b07e2be8dd9b43'
+ '58b225f304aaf42c8b8738894a10cb96'
+ '205ac79eeebb9cc43f9a0c836e60cf82'
+ 'c95b1920928f10d2c982afd7f5827a2c')
+
+package() {
+ install -D -m0644 "$srcdir"/LICENSE "$pkgdir"/usr/share/licenses/${pkgname}/LICENSE
+ install -D -m0644 "$srcdir"/scala-ide.desktop "$pkgdir"/usr/share/applications/scala-ide.desktop
+ install -D -m0644 "$srcdir"/product.png "$pkgdir"/usr/share/eclipse/dropins/scala-ide/icon.png
+
+ _dest="${pkgdir}"/usr/share/eclipse/dropins/${pkgname/eclipse-}/eclipse
+ cd "${srcdir}"/site
+
+ # Features
+ find features -type f | while read _feature ; do
+ if [[ ${_feature} =~ (.*\.jar$) ]] ; then
+ install -dm755 ${_dest}/${_feature%*.jar}
+ cd ${_dest}/${_feature/.jar}
+ jar xf ${srcdir}/site/${_feature}
+ else
+ install -Dm644 ${_feature} "${_dest}"/${_feature}
+ fi
+ done
+
+ # Plugins
+ find plugins -type f | while read _plugin ; do
+ install -Dm644 ${_plugin} "${_dest}"/${_plugin}
+ done
+}
diff --git a/product.png b/product.png
new file mode 100644
index 000000000000..b78905cc7997
--- /dev/null
+++ b/product.png
Binary files differ
diff --git a/scala-ide.desktop b/scala-ide.desktop
new file mode 100644
index 000000000000..65a059b0af3c
--- /dev/null
+++ b/scala-ide.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Type=Application
+Name=Scala-IDE
+GenericName=Scala IDE for Eclipse
+Icon=/usr/share/eclipse/dropins/scala-ide/icon.png
+Exec=/usr/bin/eclipse
+Categories=Development
+