summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302016-07-17 12:57:26 +0200
committerM0Rf302016-07-17 12:57:26 +0200
commit2a64a3e1ad1cc214f0eae5f218bb2b1905c3b222 (patch)
treec40eb52f0e602a70306170c477b716cee53ea8d2
parent26595b396e1b9d06ab4d54ddbb742011e45befb0 (diff)
downloadaur-2a64a3e1ad1cc214f0eae5f218bb2b1905c3b222.tar.gz
aligned with stable release 1.1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD27
-rw-r--r--wifiphisher.sh3
3 files changed, 19 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 645fa7e6818b..a7f6b8ff4137 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Sun Jul 17 10:57:04 UTC 2016
pkgbase = wifiphisher
pkgdesc = Fast automated phishing attacks against WPA networks.
- pkgver = 12.73f24a7
+ pkgver = 1.1
pkgrel = 1
url = https://github.com/sophron/wifiphisher
arch = any
@@ -13,8 +15,10 @@ pkgbase = wifiphisher
depends = python2-httplib2
depends = scapy
depends = aircrack-ng
- source = git+https://github.com/sophron/wifiphisher.git
- sha1sums = SKIP
+ source = https://github.com/sophron/wifiphisher/archive/v1.1.tar.gz
+ source = wifiphisher.sh
+ md5sums = 413c69ec546d647faca3120d9e074ba2
+ md5sums = 20fc8c517c5e85c8a47e2372beecd83c
pkgname = wifiphisher
diff --git a/PKGBUILD b/PKGBUILD
index 62bf126d2932..237c85990f7e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
+# Maintainer: M0Rf30
# This file is part of BlackArch Linux ( http://blackarch.org ).
# See COPYING for license details.
pkgname='wifiphisher'
-pkgver=12.73f24a7
+pkgver=1.1
pkgrel=1
groups=('blackarch' 'blackarch-wireless' 'blackarch-social')
pkgdesc='Fast automated phishing attacks against WPA networks.'
@@ -11,18 +12,11 @@ url='https://github.com/sophron/wifiphisher'
license=('MIT')
depends=('python2' 'python2-httplib2' 'scapy' 'aircrack-ng')
makedepends=('git')
-source=('git+https://github.com/sophron/wifiphisher.git')
-sha1sums=('SKIP')
-
-pkgver() {
- cd "$srcdir/wifiphisher"
-
- echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
-}
+source=("https://github.com/sophron/wifiphisher/archive/v$pkgver.tar.gz"
+ $pkgname.sh)
package() {
- cd "$srcdir/wifiphisher"
-
+ cd "$srcdir/$pkgname-$pkgver"
mkdir -p "$pkgdir/usr/bin"
mkdir -p "$pkgdir/usr/share/wifiphisher"
@@ -32,12 +26,9 @@ package() {
rm README.md LICENSE
cp -a * "$pkgdir/usr/share/wifiphisher"
-
- cat > "$pkgdir/usr/bin/wifiphisher" << EOF
-#!/bin/sh
-cd /usr/share/wifiphisher
-exec python2 wifiphisher.py "\$@"
-EOF
-
+ cp ../$pkgname.sh "$pkgdir/usr/bin/wifiphisher"
chmod a+x "$pkgdir/usr/bin/wifiphisher"
}
+
+md5sums=('413c69ec546d647faca3120d9e074ba2'
+ '20fc8c517c5e85c8a47e2372beecd83c')
diff --git a/wifiphisher.sh b/wifiphisher.sh
new file mode 100644
index 000000000000..c8e5a6d7460d
--- /dev/null
+++ b/wifiphisher.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+cd /usr/share/wifiphisher
+python2 wifiphisher.py "$@"