summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Agner2019-01-10 18:50:56 +0100
committerStefan Agner2019-01-10 18:56:52 +0100
commit2a75fde7675bfd40c35c075386f3d782cbc8af3f (patch)
treeefbe088a19fb41a116874f9954b35fa945824788
parente496c4eb46c5ed59166f3e177f8e1f933ff80b51 (diff)
downloadaur-2a75fde7675bfd40c35c075386f3d782cbc8af3f.tar.gz
bump to 2.58.2
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD71
-rw-r--r--noisy-glib-compile-schemas.diff24
3 files changed, 73 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 65d19ab435f7..abc9f0388d47 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,33 +1,34 @@
-# Generated by mksrcinfo v8
-# Do Feb 9 12:35:15 UTC 2017
pkgbase = glib2-static
pkgdesc = Low level core library. Static library.
- pkgver = 2.50.2
+ pkgver = 2.58.2
pkgrel = 1
- url = http://www.gtk.org/
- arch = i686
+ url = https://wiki.gnome.org/Projects/GLib
arch = x86_64
- license = LGPL
+ license = LGPL2.1
checkdepends = desktop-file-utils
checkdepends = dbus
makedepends = libffi
- makedepends = pcre
makedepends = zlib
makedepends = shared-mime-info
makedepends = python
makedepends = libelf
+ makedepends = git
+ makedepends = util-linux
+ makedepends = meson
+ makedepends = dbus
depends = pcre
depends = libffi
- optdepends = python2: for gdbus-codegen and gtester-report
- optdepends = elfutils: gresource inspection tool
+ optdepends = python: gdbus-codegen, glib-genmarshal, glib-mkenums, gtester-report
+ optdepends = libelf: gresource inspection tool
options = !docs
options = !libtool
options = !emptydirs
+ options = !strip
options = staticlibs
- source = http://ftp.gnome.org/pub/GNOME/sources/glib/2.50/glib-2.50.2.tar.xz
- source = revert-warn-glib-compile-schemas.patch
- sha256sums = be68737c1f268c05493e503b3b654d2b7f43d7d0b8c5556f7e4651b870acfbf5
- sha256sums = 049240975cd2f1c88fbe7deb28af14d4ec7d2640495f7ca8980d873bb710cc97
+ source = git+https://gitlab.gnome.org/GNOME/glib.git#commit=97bcbcb8c2aa0aeee5afd9939efbadbae0c8a8fa
+ source = noisy-glib-compile-schemas.diff
+ sha256sums = SKIP
+ sha256sums = 81a4df0b638730cffb7fa263c04841f7ca6b9c9578ee5045db6f30ff0c3fc531
pkgname = glib2-static
diff --git a/PKGBUILD b/PKGBUILD
index d4920ea7d57f..bce8504563da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,53 +1,52 @@
pkgname=glib2-static
-pkgver=2.50.2
+pkgver=2.58.2
pkgrel=1
pkgdesc="Low level core library. Static library."
-url="http://www.gtk.org/"
-arch=(i686 x86_64)
-makedepends=(libffi pcre zlib shared-mime-info python libelf)
-checkdepends=(desktop-file-utils dbus)
-optdepends=('python2: for gdbus-codegen and gtester-report'
- 'elfutils: gresource inspection tool')
-options=('!docs' '!libtool' '!emptydirs' 'staticlibs')
+url="https://wiki.gnome.org/Projects/GLib"
+license=(LGPL2.1)
+arch=(x86_64)
depends=(pcre libffi)
-license=(LGPL)
-source=(http://ftp.gnome.org/pub/GNOME/sources/glib/${pkgver%.*}/glib-$pkgver.tar.xz
- revert-warn-glib-compile-schemas.patch)
-sha256sums=('be68737c1f268c05493e503b3b654d2b7f43d7d0b8c5556f7e4651b870acfbf5'
- '049240975cd2f1c88fbe7deb28af14d4ec7d2640495f7ca8980d873bb710cc97')
+makedepends=(libffi zlib shared-mime-info python libelf git util-linux meson dbus)
+checkdepends=(desktop-file-utils dbus)
+optdepends=('python: gdbus-codegen, glib-genmarshal, glib-mkenums, gtester-report'
+ 'libelf: gresource inspection tool')
+options=('!docs' '!libtool' '!emptydirs' '!strip' 'staticlibs')
+_commit=97bcbcb8c2aa0aeee5afd9939efbadbae0c8a8fa # tags/2.58.2^0
+source=("git+https://gitlab.gnome.org/GNOME/glib.git#commit=$_commit"
+ noisy-glib-compile-schemas.diff)
+sha256sums=('SKIP'
+ '81a4df0b638730cffb7fa263c04841f7ca6b9c9578ee5045db6f30ff0c3fc531')
+
+pkgver() {
+ cd glib
+ git describe --tags | sed 's/-/+/g'
+}
prepare() {
- cd glib-$pkgver
- patch -Rp1 -i ../revert-warn-glib-compile-schemas.patch
- NOCONFIGURE=1 ./autogen.sh
+ cd glib
+
+ # Suppress noise from glib-compile-schemas.hook
+ patch -Np1 -i ../noisy-glib-compile-schemas.diff
}
build() {
- cd glib-$pkgver
- PYTHON=/usr/bin/python2 ./configure --prefix=/usr --libdir=/usr/lib \
- --sysconfdir=/etc \
- --with-pcre=system \
- --disable-fam --enable-static
- sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
- make
+ arch-meson glib build \
+ --default-library static \
+ -D selinux=false \
+ -D man=true \
+ -D gtk_doc=false \
+ -Dinternal_pcre=false \
+ -Dfam=false
+ ninja -C build
}
check() {
- cd glib-$pkgver
- if ! make check; then
- # Rounding error in timer tests?
- # GLib:ERROR:timer.c:38:test_timer_basic: assertion failed (micros == ((guint64)(elapsed * 1e6)) % 1000000): (1 == 0)
- make check
- fi
+ meson test -C build
}
-
package() {
- cd glib-$pkgver
- make completiondir=/usr/share/bash-completion/completions DESTDIR="$pkgdir" install
- for _i in "$pkgdir/usr/share/bash-completion/completions/"*; do
- chmod -x "$_i"
- done
- # Our gdb does not ship the required python modules, so remove it
+ DESTDIR="$pkgdir" meson install -C build
+
+ # Only install static library
rm -rf "$pkgdir/usr/"{bin,include,share,lib/glib-2.0,lib/pkgconfig} $pkgdir/usr/lib/*.so*
}
diff --git a/noisy-glib-compile-schemas.diff b/noisy-glib-compile-schemas.diff
new file mode 100644
index 000000000000..f5f2d9482229
--- /dev/null
+++ b/noisy-glib-compile-schemas.diff
@@ -0,0 +1,24 @@
+diff --git i/gio/glib-compile-schemas.c w/gio/glib-compile-schemas.c
+index b8de0907248f6860..130f89b1728f7932 100644
+--- i/gio/glib-compile-schemas.c
++++ w/gio/glib-compile-schemas.c
+@@ -1219,19 +1219,6 @@ parse_state_start_schema (ParseState *state,
+ return;
+ }
+
+- if (path && (g_str_has_prefix (path, "/apps/") ||
+- g_str_has_prefix (path, "/desktop/") ||
+- g_str_has_prefix (path, "/system/")))
+- {
+- gchar *message = NULL;
+- message = g_strdup_printf (_("Warning: Schema “%s” has path “%s”. "
+- "Paths starting with "
+- "“/apps/”, “/desktop/” or “/system/” are deprecated."),
+- id, path);
+- g_printerr ("%s\n", message);
+- g_free (message);
+- }
+-
+ state->schema_state = schema_state_new (path, gettext_domain,
+ extends, extends_name, list_of);
+