summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-03-19 23:05:49 -0500
committerLuis Martinez2022-03-19 23:05:49 -0500
commit2a7dbbf6e052ec6ffae19720cd1091df4cdc4ac7 (patch)
tree61c4609f9da5d01bf59c70ed12938afac1e61c54
parent1460a4e4aa3db8c74798745068e6ffd670376a1c (diff)
downloadaur-2a7dbbf6e052ec6ffae19720cd1091df4cdc4ac7.tar.gz
update to 1.1.0
-rw-r--r--.SRCINFO6
-rw-r--r--CHANGELOG.md17
-rw-r--r--PKGBUILD4
3 files changed, 22 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e810d3d925e0..29e5f5535e04 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hilbish
pkgdesc = The flower shell for Lua users
- pkgver = 1.0.4
+ pkgver = 1.1.0
pkgrel = 1
url = https://github.com/rosettea/hilbish
install = hilbish.install
@@ -14,7 +14,7 @@ pkgbase = hilbish
depends = lua-succulent
depends = lua-inspect
options = !emptydirs
- source = hilbish-1.0.4.tar.gz::https://github.com/rosettea/hilbish/archive/v1.0.4.tar.gz
- sha256sums = 4e84db4b3ebd559c474240af01c9b02b7a1525f883f5e69984e8c6b9c4196d02
+ source = hilbish-1.1.0.tar.gz::https://github.com/rosettea/hilbish/archive/v1.1.0.tar.gz
+ sha256sums = b86813a67428f45a2aec601871f4df53a3ca5bf8e6666d8ea76d799ce3c9a8fe
pkgname = hilbish
diff --git a/CHANGELOG.md b/CHANGELOG.md
index d2a28ca9336f..f76613888d62 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,5 +1,21 @@
# 🎀 Changelog
+## [1.1.0] - 2021-03-17
+### Added
+- `hilbish.vimAction` hook (`doc vimMode actions`)
+- `command.not-executable` hook (will replace `command.no-perm` in a future release)
+
+### Fixed
+- Check if interactive before adding to history
+- Escape in vim mode exits all modes and not only insert
+- Make 2nd line in prompt empty if entire prompt is 1 line
+- Completion menu doesnt appear if there is only 1 result
+- Ignore SIGQUIT, which caused a panic unhandled
+- Remove hostname in greeting on Windows
+- Handle PATH binaries properly on Windows
+- Fix removal of dot in the beginning of folders/files that have them for file complete
+- Fix prompt being set to the continue prompt even when exited
+
## [1.0.4] - 2021-03-12
### Fixed
- Panic when history directory doesn't exist
@@ -392,6 +408,7 @@ This input for example will prompt for more input to complete:
First "stable" release of Hilbish.
+[1.1.0]: https://github.com/Rosettea/Hilbish/compare/v1.0.4...v1.1.0
[1.0.4]: https://github.com/Rosettea/Hilbish/compare/v1.0.3...v1.0.4
[1.0.3]: https://github.com/Rosettea/Hilbish/compare/v1.0.2...v1.0.3
[1.0.2]: https://github.com/Rosettea/Hilbish/compare/v1.0.1...v1.0.2
diff --git a/PKGBUILD b/PKGBUILD
index 9cd77a17cbc0..9b797521b457 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
pkgname=hilbish
-pkgver=1.0.4
+pkgver=1.1.0
pkgrel=1
pkgdesc="The flower shell for Lua users"
arch=('x86_64' 'i686' 'aarch64')
@@ -13,7 +13,7 @@ install="$pkgname.install"
options=('!emptydirs')
changelog=CHANGELOG.md
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('4e84db4b3ebd559c474240af01c9b02b7a1525f883f5e69984e8c6b9c4196d02')
+sha256sums=('b86813a67428f45a2aec601871f4df53a3ca5bf8e6666d8ea76d799ce3c9a8fe')
prepare() {
cd "Hilbish-$pkgver"