summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSkycoder422022-08-20 16:21:30 +0000
committerSkycoder422022-08-20 16:21:30 +0000
commit2abf530493e717b5eb372e8ce38677c0170b1f97 (patch)
tree06944ed95a360bc89b1f86ca370f0da2ac39ff2c
parentf35579b5cd474f8d9ebcc8d92f6b3abb5565d90a (diff)
downloadaur-2abf530493e717b5eb372e8ce38677c0170b1f97.tar.gz
Update paxchange to version 1.1.0
-rw-r--r--.SRCINFO6
-rw-r--r--CHANGELOG.md4
-rw-r--r--PKGBUILD10
-rw-r--r--paxchange.rule1
4 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c8b612b980d..4b241e3174c4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = paxchange
pkgdesc = Simple dart script to passively synchronize installed pacman packages between systems.
- pkgver = 1.0.2
+ pkgver = 1.1.0
pkgrel = 1
epoch = 2
url = https://github.com/Skycoder42/paxchange
@@ -16,7 +16,7 @@ pkgbase = paxchange
depends = pacman
options = !strip
backup = etc/paxchange.json
- source = paxchange-1.0.2.tar.gz::https://github.com/Skycoder42/paxchange/archive/refs/tags/v1.0.2.tar.gz
- b2sums = e7b338efea5db22111db6e84bfb8ee491927681f48edc7abce197df2c4d43ed73c8c089a9115734aad2b226fe2e8dce567fbccf1e4649f717ca92288775da9ab
+ source = paxchange-1.1.0.tar.gz::https://github.com/Skycoder42/paxchange/archive/refs/tags/v1.1.0.tar.gz
+ b2sums = cfed8f195f3ad2d0029f8e4cba079782734d6ccc4d99e41577610c1f93f919e2fedc1b701bb3acfd72a8b74a296161262ab013981768c67247a86e13150948f7
pkgname = paxchange
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 2d90d8dda367..8a1508ebd185 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -4,6 +4,10 @@ All notable changes to this project will be documented in this file.
The format is based on Keep a Changelog](https://keepachangelog.com/en/1.0.0/),
and this project adheres to Semantic Versioning](https://semver.org/spec/v2.0.0.html).
+## 1.1.0
+- Detect packages that are implicitly installed when reviewing
+- Add options to mark packages as explicitly or implicitly installed
+
## 1.0.2
- Minor fix-ups and improvements
diff --git a/PKGBUILD b/PKGBUILD
index 7d1206a39ad1..94b2136e032e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Skycoder42 <Skycoder42@users.noreply.github.com>
pkgname='paxchange'
pkgdesc='Simple dart script to passively synchronize installed pacman packages between systems.'
-pkgver='1.0.2'
+pkgver='1.1.0'
pkgrel=1
epoch=2
arch=('x86_64' 'i686' 'armv7h' 'aarch64')
@@ -9,9 +9,9 @@ url='https://github.com/Skycoder42/paxchange'
license=('BSD')
depends=('pacman')
makedepends=('dart>=2.17.0' 'dart<3.0.0')
-_pkgdir='paxchange-1.0.2'
-source=("$_pkgdir.tar.gz::https://github.com/Skycoder42/paxchange/archive/refs/tags/v1.0.2.tar.gz")
-b2sums=('e7b338efea5db22111db6e84bfb8ee491927681f48edc7abce197df2c4d43ed73c8c089a9115734aad2b226fe2e8dce567fbccf1e4649f717ca92288775da9ab')
+_pkgdir='paxchange-1.1.0'
+source=("$_pkgdir.tar.gz::https://github.com/Skycoder42/paxchange/archive/refs/tags/v1.1.0.tar.gz")
+b2sums=('cfed8f195f3ad2d0029f8e4cba079782734d6ccc4d99e41577610c1f93f919e2fedc1b701bb3acfd72a8b74a296161262ab013981768c67247a86e13150948f7')
install='paxchange.install'
changelog='CHANGELOG.md'
backup=('etc/paxchange.json')
@@ -31,7 +31,7 @@ build() {
check() {
cd "$_pkgdir"
dart analyze --no-fatal-warnings
- dart test
+ dart test test/unit
}
package() {
diff --git a/paxchange.rule b/paxchange.rule
deleted file mode 100644
index c9102f02c9d1..000000000000
--- a/paxchange.rule
+++ /dev/null
@@ -1 +0,0 @@
-qt5-base qt5-jsonserializer