summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-11-20 18:10:37 +0800
committerzxp198210052023-11-20 18:10:37 +0800
commit2b30772ea34e313bbe81a1529869041def8c5dfa (patch)
tree593d5a6949c7e265901d433813b4377e6459114c
parent7e6d18799a8610da0351478bc714c521817ff64d (diff)
downloadaur-2b30772ea34e313bbe81a1529869041def8c5dfa.tar.gz
fix errors
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD47
-rw-r--r--dbgate.sh5
3 files changed, 44 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 91f68d24a29b..cc263f07f8af 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,27 @@
pkgbase = dbgate-bin
pkgdesc = Database manager for MySQL, PostgreSQL, SQL Server, MongoDB, SQLite and others. Runs under Windows, Linux, Mac or as web application
pkgver = 5.2.7
- pkgrel = 1
+ pkgrel = 2
url = https://dbgate.org/
arch = aarch64
arch = armv7h
arch = x86_64
license = MIT
- makedepends = asar
makedepends = squashfuse
- depends = bash
depends = electron25
depends = hicolor-icon-theme
+ depends = libx11
+ depends = gdk-pixbuf2
+ depends = libxext
+ depends = libdbusmenu-glib
+ depends = gtk2
+ depends = dbus-glib
provides = dbgate=5.2.7
conflicts = dbgate
source = LICENSE::https://raw.githubusercontent.com/dbgate/dbgate/v5.2.7/LICENSE
source = dbgate.sh
sha256sums = 4ba7d897a31d45781b6bbc0b87e9a241873d61fff657af2f0c54608f652d235b
- sha256sums = e493cab8937b9d0845ddeb0c8e662ee2e5ec2f8f7f79caa08b1e94186aaf4371
+ sha256sums = 69c0eae56bae86fa84956e942f5050340bf186f81da7f06bb5db85b3be34afb7
source_aarch64 = dbgate-5.2.7-aarch64.AppImage::https://github.com/dbgate/dbgate/releases/download/v5.2.7/dbgate-5.2.7-linux_arm64.AppImage
sha256sums_aarch64 = c0f659c4feb350067b29c202656669b3dabb19a9626f6a2df3a51a7116a56a22
source_armv7h = dbgate-5.2.7-armv7h.AppImage::https://github.com/dbgate/dbgate/releases/download/v5.2.7/dbgate-5.2.7-linux_armv7l.AppImage
diff --git a/PKGBUILD b/PKGBUILD
index 44ebc534754f..f97531e4109c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,37 +2,54 @@
# Contributor: aulonsal <seraur at aulonsal dot com>
pkgname=dbgate-bin
pkgver=5.2.7
-pkgrel=1
+pkgrel=2
pkgdesc="Database manager for MySQL, PostgreSQL, SQL Server, MongoDB, SQLite and others. Runs under Windows, Linux, Mac or as web application"
-arch=('aarch64' 'armv7h' 'x86_64')
+arch=(
+ 'aarch64'
+ 'armv7h'
+ 'x86_64'
+)
url="https://dbgate.org/"
-_githuburl="https://github.com/dbgate/dbgate"
+_ghurl="https://github.com/dbgate/dbgate"
license=('MIT')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
-depends=('bash' 'electron25' 'hicolor-icon-theme')
-makedepends=('asar' 'squashfuse')
-source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.AppImage::${_githuburl}/releases/download/v${pkgver}/${pkgname%-bin}-${pkgver}-linux_arm64.AppImage")
-source_armv7h=("${pkgname%-bin}-${pkgver}-armv7h.AppImage::${_githuburl}/releases/download/v${pkgver}/${pkgname%-bin}-${pkgver}-linux_armv7l.AppImage")
-source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.AppImage::${_githuburl}/releases/download/v${pkgver}/${pkgname%-bin}-${pkgver}-linux_x86_64.AppImage")
-source=("LICENSE::https://raw.githubusercontent.com/dbgate/dbgate/v${pkgver}/LICENSE"
- "${pkgname%-bin}.sh")
+depends=(
+ 'electron25'
+ 'hicolor-icon-theme'
+ 'libx11'
+ 'gdk-pixbuf2'
+ 'libxext'
+ 'libdbusmenu-glib'
+ 'gtk2'
+ 'dbus-glib'
+)
+makedepends=(
+ 'squashfuse'
+)
+source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.AppImage::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}-${pkgver}-linux_arm64.AppImage")
+source_armv7h=("${pkgname%-bin}-${pkgver}-armv7h.AppImage::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}-${pkgver}-linux_armv7l.AppImage")
+source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.AppImage::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}-${pkgver}-linux_x86_64.AppImage")
+source=(
+ "LICENSE::https://raw.githubusercontent.com/dbgate/dbgate/v${pkgver}/LICENSE"
+ "${pkgname%-bin}.sh"
+)
sha256sums=('4ba7d897a31d45781b6bbc0b87e9a241873d61fff657af2f0c54608f652d235b'
- 'e493cab8937b9d0845ddeb0c8e662ee2e5ec2f8f7f79caa08b1e94186aaf4371')
+ '69c0eae56bae86fa84956e942f5050340bf186f81da7f06bb5db85b3be34afb7')
sha256sums_aarch64=('c0f659c4feb350067b29c202656669b3dabb19a9626f6a2df3a51a7116a56a22')
sha256sums_armv7h=('cc0c7b59475a254bda665b835dcf7f145813f2daa5687dc41e2116b13195fd04')
sha256sums_x86_64=('75801a25bcd13b1f1073f2c8c048f49c7ebe58eb1162f5105b486a0ce99a8696')
build() {
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}-${CARCH}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}-${CARCH}.AppImage" --appimage-extract > /dev/null
- asar e "${srcdir}/squashfs-root/resources/app.asar" "${srcdir}/app.asar.unpacked"
- cp -r "${srcdir}/squashfs-root/resources/app.asar.unpacked" "${srcdir}"
- asar p "${srcdir}/app.asar.unpacked" "${srcdir}/app.asar"
sed "s|AppRun --no-sandbox %U|${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
- install -Dm644 "${srcdir}/app.asar" -t "${pkgdir}/opt/${pkgname%-bin}/resources"
+ install -Dm644 "${srcdir}/squashfs-root/resources/app.asar" -t "${pkgdir}/usr/lib/${pkgname%-bin}"
+ cp -r "${srcdir}/squashfs-root/resources/app.asar.unpacked" "${pkgdir}/usr/lib/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/squashfs-root/swiftshader/"* -t "${pkgdir}/usr/lib/${pkgname%-bin}/swiftshader"
+ install -Dm644 "${srcdir}/squashfs-root/usr/lib/"* -t "${pkgdir}/usr/lib/${pkgname%-bin}/lib"
for _icons in 16x16 32x32 48x48 64x64 128x128 256x256 512x512;do
install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/${_icons}/apps/${pkgname%-bin}.png" \
-t "${pkgdir}/usr/share/icons/hicolor/${_icons}/apps"
diff --git a/dbgate.sh b/dbgate.sh
index 1b3e5451a368..e14765e3425f 100644
--- a/dbgate.sh
+++ b/dbgate.sh
@@ -1,6 +1,9 @@
#!/bin/bash
_ELECTRON=/usr/bin/electron25
-_ASAR="/opt/dbgate/resources/app.asar"
+APPDIR=/usr/lib/dbgate
+export PATH="${APPDIR}:${PATH}"
+export LD_LIBRARY_PATH="${APPDIR}/swiftshader:${APPDIR}/lib:${LD_LIBRARY_PATH}"
+_ASAR="${APPDIR}/app.asar"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
exec ${_ELECTRON} ${_ASAR} "$@"
else