summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJose Riha2021-03-23 12:07:04 +0100
committerJose Riha2021-03-23 12:07:04 +0100
commit2b358abc4ef1c3511a547ad3bfa94a443bd46d50 (patch)
treebc3c130feff28fd5f1139a2fa7ed2e66b63c602a
parenta83ad102ba53adf62bd36364fe8a68befd124023 (diff)
downloadaur-2b358abc4ef1c3511a547ad3bfa94a443bd46d50.tar.gz
Update
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD15
2 files changed, 9 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 938d863e945e..54e164dae046 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-birdseye
pkgdesc = Graphical Python debugger which lets you view the values of all evaluated expressions
- pkgver = 0.8.4
+ pkgver = 0.9.0
pkgrel = 1
url = http://github.com/alexmojaki/birdseye
arch = any
@@ -16,8 +16,9 @@ pkgbase = python-birdseye
depends = python-cached-property
depends = python-future
depends = python-asttokens
- source = https://files.pythonhosted.org/packages/source/b/birdseye/birdseye-0.8.4.tar.gz
- sha256sums = 34fbf3a042f257e981cb0d4849d279457269d212851404b19bf9635af71e0701
+ noextract = birdseye-0.9.0-py3-none-any.whl
+ source = https://files.pythonhosted.org/packages/d3/9e/de1d443e0b307f696a9103b4c8fd5e7f253a51a366124139446b7d9c7c23/birdseye-0.9.0-py3-none-any.whl
+ sha256sums = 03c249beaf4770efa8751ed32d5d3c5e6609180339121bc54fbf75531b51fc43
pkgname = python-birdseye
diff --git a/PKGBUILD b/PKGBUILD
index b2348c6ff4fa..04df27d5e42e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=python-birdseye
_module=birdseye
-pkgver=0.8.4
+pkgver=0.9.0
pkgrel=1
pkgdesc="Graphical Python debugger which lets you view the values of all evaluated expressions"
url="http://github.com/alexmojaki/birdseye"
@@ -10,15 +10,10 @@ depends=(python-littleutils python-flask-humanize python-humanize python-flask-h
makedepends=('python-setuptools')
license=('MIT')
arch=('any')
-source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
-sha256sums=('34fbf3a042f257e981cb0d4849d279457269d212851404b19bf9635af71e0701')
-
-build() {
- cd "${srcdir}/${_module}-${pkgver}"
- python setup.py build
-}
+source=("https://files.pythonhosted.org/packages/d3/9e/de1d443e0b307f696a9103b4c8fd5e7f253a51a366124139446b7d9c7c23/birdseye-${pkgver}-py3-none-any.whl")
+noextract=("birdseye-${pkgver}-py3-none-any.whl")
+sha256sums=('03c249beaf4770efa8751ed32d5d3c5e6609180339121bc54fbf75531b51fc43')
package() {
- cd "${srcdir}/${_module}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps *.whl
}