summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTobias Bachmann2023-07-13 19:58:56 +0200
committerTobias Bachmann2023-07-13 19:58:56 +0200
commit2b4686b63a1f18b9cb258d444bf81f88f7bf12dc (patch)
tree5345717ed860270f52976f7663c4e784408af69d
parentbd27301e0964614ee0a7289c0daf64a48e09e663 (diff)
downloadaur-2b4686b63a1f18b9cb258d444bf81f88f7bf12dc.tar.gz
Version bump
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD12
2 files changed, 16 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d8b879ce86ae..474157e7afea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = fsleyes
pkgdesc = FSLeyes is the FSL image viewer
- pkgver = 1.5.0
+ pkgver = 1.7.0
pkgrel = 1
url = https://fsl.fmrib.ox.ac.uk/fsl/fslwiki/FSLeyes
arch = any
@@ -24,12 +24,12 @@ pkgbase = fsleyes
depends = python-pytest-timeout
depends = python-pytest-xdist
depends = python-certifi
- depends = python-wxpython>=4.0.1-2
+ depends = python-wxpython
depends = python-xarray
depends = python-parse
- depends = fslpy>=3.10.0
- depends = fsleyes-widgets>=0.12.3
- depends = fsleyes-props>=1.8.2
+ depends = fslpy>=3.13.0
+ depends = fsleyes-widgets>=0.14.3
+ depends = fsleyes-props>=1.9.6
depends = python-file-tree>=0.4.0
optdepends = fsl: Enable loading standard images and advanced features (highly recommended)
optdepends = python-wxnatpy: Enable loading overlay from XNAT
@@ -37,9 +37,9 @@ pkgbase = fsleyes
optdepends = python-rtree
optdepends = jupyter-notebook
optdepends = python-trimesh
- source = https://git.fmrib.ox.ac.uk/fsl/fsleyes/fsleyes/-/archive/1.5.0/fsleyes-1.5.0.tar.gz
+ source = https://git.fmrib.ox.ac.uk/fsl/fsleyes/fsleyes/-/archive/1.7.0/fsleyes-1.7.0.tar.gz
source = fsleyes.desktop
- sha256sums = 0e58fc9505901bf2ddd971f75de97fe978d80c02e200ecac84cca976e1eba0f3
+ sha256sums = ab5eb2e5e5147f6ffd9701f49db319d8f3ab755eda3c593f191be7a13c891fc5
sha256sums = 6e91e88eb74602f8da7cda6575245dbaaf4577022bffe15c0efedb33106139fb
pkgname = fsleyes
diff --git a/PKGBUILD b/PKGBUILD
index f575a77a02bc..43d020792eec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Tobias Bachmann <tobachmann@gmx.de>
pkgname=fsleyes
-pkgver=1.5.0
+pkgver=1.7.0
pkgrel=1
pkgdesc="FSLeyes is the FSL image viewer"
arch=('any')
url="https://fsl.fmrib.ox.ac.uk/fsl/fslwiki/FSLeyes"
license=('Apache')
groups=()
-depends=('python' 'python-setuptools' 'python-sphinx' 'python-six' 'python-numpy' 'python-dill' 'python-matplotlib' 'python-nibabel' 'python-jinja' 'python-opengl' 'python-pyparsing' 'python-pillow' 'python-scipy' 'python-opengl-accelerate' 'python-wheel' 'python-twine' 'python-pytest-timeout' 'python-pytest-xdist' 'python-certifi' 'python-wxpython>=4.0.1-2' 'python-xarray' 'python-parse' 'fslpy>=3.10.0' 'fsleyes-widgets>=0.12.3' 'fsleyes-props>=1.8.2' 'python-file-tree>=0.4.0')
+depends=('python' 'python-setuptools' 'python-sphinx' 'python-six' 'python-numpy' 'python-dill' 'python-matplotlib' 'python-nibabel' 'python-jinja' 'python-opengl' 'python-pyparsing' 'python-pillow' 'python-scipy' 'python-opengl-accelerate' 'python-wheel' 'python-twine' 'python-pytest-timeout' 'python-pytest-xdist' 'python-certifi' 'python-wxpython' 'python-xarray' 'python-parse' 'fslpy>=3.13.0' 'fsleyes-widgets>=0.14.3' 'fsleyes-props>=1.9.6' 'python-file-tree>=0.4.0')
optdepends=('fsl: Enable loading standard images and advanced features (highly recommended)'
'python-wxnatpy: Enable loading overlay from XNAT'
'python-indexed-gzip: Fast random access of gzipped image files'
@@ -20,7 +20,7 @@ conflicts=()
replaces=()
source=("https://git.fmrib.ox.ac.uk/fsl/${pkgname}/${pkgname}/-/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz"
"${pkgname}.desktop")
-sha256sums=('0e58fc9505901bf2ddd971f75de97fe978d80c02e200ecac84cca976e1eba0f3'
+sha256sums=('ab5eb2e5e5147f6ffd9701f49db319d8f3ab755eda3c593f191be7a13c891fc5'
'6e91e88eb74602f8da7cda6575245dbaaf4577022bffe15c0efedb33106139fb')
package() {
@@ -31,4 +31,10 @@ package() {
install -Dm644 ./fsleyes/assets/icons/app_icon/fsleyes.iconset/icon_512x512.png "${pkgdir}"/usr/share/icons/hicolor/512x512/apps/${pkgname}.png
install -Dm644 "${srcdir}"/${pkgname}.desktop "${pkgdir}"/usr/share/applications/${pkgname}.desktop
+
+ # Add python pth file to let FSLeyes find the fsl python module
+ sitepackages_path=$(python3 -c "import sysconfig; print(sysconfig.get_path('purelib'))")
+ mkdir -p "${pkgdir}"/"${sitepackages_path}"
+ echo "/opt/fsl/lib/python3.11/site-packages" > "${pkgdir}"/"${sitepackages_path}"/fsl.pth
+ echo "/opt/fsl/lib/python3.10/site-packages" >> "${pkgdir}"/"${sitepackages_path}"/fsl.pth
}