summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-08-16 16:28:59 -0500
committerLuis Martinez2022-08-16 16:28:59 -0500
commit2b4c01b122287f536b06828929e9155e767ae15d (patch)
treefb331517c56a0ae9bcc4ee50fe02c0797f285db3
parentc5f163525591c6442a3d99346250ae4fe178c86f (diff)
downloadaur-2b4c01b122287f536b06828929e9155e767ae15d.tar.gz
update to 0.6.4
-rw-r--r--.SRCINFO9
-rw-r--r--CHANGELOG.md77
-rw-r--r--PKGBUILD12
-rw-r--r--header.patch12
4 files changed, 86 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fe6292c3a7f8..c4120cbf5be1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = python-ripser
pkgdesc = Homology Library for Python
- pkgver = 0.6.1
+ pkgver = 0.6.4
pkgrel = 1
url = https://github.com/scikit-tda/ripser.py
+ changelog = CHANGELOG.md
arch = x86_64
license = MIT
makedepends = cython
@@ -14,11 +15,9 @@ pkgbase = python-ripser
depends = python-scipy
depends = python-scikit-learn
depends = python-persim
- source = python-ripser-0.6.1.tar.gz::https://files.pythonhosted.org/packages/source/r/ripser/ripser-0.6.1.tar.gz
+ source = python-ripser-0.6.4.tar.gz::https://files.pythonhosted.org/packages/source/r/ripser/ripser-0.6.4.tar.gz
source = setup.py.patch
- source = header.patch
- sha256sums = 335112a0f94532ccbe686db7826ee8d0714b32f65891abf92c0a02f3cb0fc5fd
+ sha256sums = 7a9b3e9420869c50df85e9a446c912b8af81621e62ca1af8f9492c6335b7e594
sha256sums = 5d6538cf07d897cfead808048682266bcf2a9199f2ddda9becd4919221612195
- sha256sums = cd5b619ce29859d26890e9256f3e883c463c1196c3e9a172b7de264584990a4a
pkgname = python-ripser
diff --git a/CHANGELOG.md b/CHANGELOG.md
new file mode 100644
index 000000000000..1cbbb1cc6678
--- /dev/null
+++ b/CHANGELOG.md
@@ -0,0 +1,77 @@
+# 0.6.4
+ - Add some includes to ripser.cpp for newer Ubuntu/C++ environments
+
+# 0.6.3
+ - Update numpy header
+
+# 0.6.2
+ - Prevent simplex assembly in last dimension for improved memory usage (courtesy of Umberto Lupo)
+
+# 0.6.1
+ - Lazy import plotting dependencies
+
+# 0.6.0
+ - Update C++ backend to commit 286d369 of [ripser](https://github.com/Ripser/ripser) but keeping same functionalities
+ - Add support to robinhood hashmap into the C++ Backend
+ - Update CI in order to compile C++ with robinhood enable
+ - Enable Enclosing radius when threshold is set to infinity
+
+# 0.5.5
+ - Updating CI/CD pipeline.
+
+# 0.5.4
+ - Fixing issue with inconsistent answers from different scipy.sparse formats, courtesy of Umberto Lupo
+
+# 0.5.3
+ - Adding link to ripser++ GPU version by Simon Zhang
+
+# 0.5.2:
+ - Cocycle indices now correspond to point cloud indices, even
+ when a greedy permutation is in use
+
+# 0.4.1:
+ - Fixed packing so C++ is MSVC compatible.
+
+# 0.4.0:
+ - Added license to distributed packages.
+
+# 0.3.2:
+ - Added support for greedy permutations.
+ - Outsourced plotting to persim.
+ - Outsourced data construction in examples to tadasets.
+ - Revamped documentation.
+
+# 0.3.0:
+ - Completed JOSS review, thanks @lmcinnes and @arokem!!
+ - Documentation details updated.
+
+# 0.2.7:
+ - Updating home url
+
+# 0.2.6:
+ - Update license to MIT.
+
+# 0.2.5:
+ - Docs and notebooks revamp.
+ - Support for Windows.
+
+# 0.2.4:
+ - Interface redesign
+
+# 0.2.3:
+ - Support for lower star filtrations
+ - Notebook on lower star filtrations
+
+# 0.2.1:
+ - Sparse distance matrix support
+ - Two additional notebooks about sparsity
+ - Language agnostic bindings support
+ - Bug fixes (filtrations with low number of points)
+
+# 0.2.0:
+ - Bug fixes (int rounding error for small magnitude threshold)
+
+# 0.1.7:
+ - Generation of cocycles.
+ - Handle inf in C code and in plotting.
+ - Many new options for plotting diagrams.
diff --git a/PKGBUILD b/PKGBUILD
index 837c18097a36..027ac298758b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=python-ripser
_pkg="${pkgname#python-}"
-pkgver=0.6.1
+pkgver=0.6.4
pkgrel=1
pkgdesc="Homology Library for Python"
arch=('x86_64')
@@ -11,15 +11,13 @@ url="https://github.com/scikit-tda/ripser.py"
license=('MIT')
depends=('python-numpy' 'python-scipy' 'python-scikit-learn' 'python-persim')
makedepends=('cython' 'python-build' 'python-installer' 'python-setuptools' 'python-wheel')
+changelog=CHANGELOG.md
source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/r/$_pkg/$_pkg-$pkgver.tar.gz"
- 'setup.py.patch'
- 'header.patch')
-sha256sums=('335112a0f94532ccbe686db7826ee8d0714b32f65891abf92c0a02f3cb0fc5fd'
- '5d6538cf07d897cfead808048682266bcf2a9199f2ddda9becd4919221612195'
- 'cd5b619ce29859d26890e9256f3e883c463c1196c3e9a172b7de264584990a4a')
+ 'setup.py.patch')
+sha256sums=('7a9b3e9420869c50df85e9a446c912b8af81621e62ca1af8f9492c6335b7e594'
+ '5d6538cf07d897cfead808048682266bcf2a9199f2ddda9becd4919221612195')
prepare() {
- patch -p1 -d "$_pkg-$pkgver" < header.patch
patch -p1 -d "$_pkg-$pkgver" < setup.py.patch
}
diff --git a/header.patch b/header.patch
deleted file mode 100644
index 98c0445c9fc7..000000000000
--- a/header.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/ripser/ripser.cpp b/ripser/ripser.cpp
-index f2b7531..2c225c5 100644
---- a/ripser/ripser.cpp
-+++ b/ripser/ripser.cpp
-@@ -46,6 +46,7 @@ derivative works thereof, in binary and source code form.
- #include <iomanip>
- #include <iostream>
- #include <iterator>
-+#include <limits>
- #include <numeric>
- #include <queue>
- #include <sstream>