summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMario Finelli2021-10-05 16:37:53 -0400
committerMario Finelli2021-10-05 16:37:53 -0400
commit2b64191de93f4f4e475ff6ef203798710579e599 (patch)
treed0a5e6d0bfc1b3476cd8a49fad62595e1f52fb1d
parent87e29d9c80fa409d505600ddb3f3c833b10376bd (diff)
downloadaur-2b64191de93f4f4e475ff6ef203798710579e599.tar.gz
upgpkg: helm-gcs 0.3.18-1
upstream release
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD5
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c12b64ca2829..9bf76fb02c90 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = helm-gcs
pkgdesc = Helm plugin to manage chart repositories on GCS
- pkgver = 0.3.16
+ pkgver = 0.3.18
pkgrel = 1
url = https://github.com/hayorov/helm-gcs
install = helm-gcs.install
@@ -9,7 +9,7 @@ pkgbase = helm-gcs
makedepends = go
depends = bash
depends = helm
- source = https://github.com/hayorov/helm-gcs/archive/0.3.16/helm-gcs-0.3.16.tar.gz
- sha256sums = a4168ec2b0871455a0b39d8c5272466a9086f26aeb729e09b89a920d3c7fa238
+ source = https://github.com/hayorov/helm-gcs/archive/0.3.18/helm-gcs-0.3.18.tar.gz
+ sha256sums = 2028ffa0042b15d9bbdecf1d8d9bd48bf6a56d8d7bde442f703d6ae1d358b75a
pkgname = helm-gcs
diff --git a/PKGBUILD b/PKGBUILD
index 494f40e77529..9c45da95ce7e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mario Finelli <mario at finel dot li>
pkgname=helm-gcs
-pkgver=0.3.16
+pkgver=0.3.18
pkgrel=1
pkgdesc="Helm plugin to manage chart repositories on GCS"
arch=(x86_64)
@@ -11,10 +11,11 @@ install=helm-gcs.install
depends=(bash helm)
makedepends=(go)
source=("https://github.com/hayorov/helm-gcs/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('a4168ec2b0871455a0b39d8c5272466a9086f26aeb729e09b89a920d3c7fa238')
+sha256sums=('2028ffa0042b15d9bbdecf1d8d9bd48bf6a56d8d7bde442f703d6ae1d358b75a')
prepare() {
cd "${pkgname}-${pkgver}"
+ go mod tidy # upstream released a dirty mod file; remove on next release
go mod download
sed -i '/^hooks:$/Q' plugin.yaml
}