summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAllen2019-02-24 20:06:33 +0800
committerAllen2019-02-24 20:06:33 +0800
commit2b68f105f653461e2065a561fbac281be94bc474 (patch)
treec146eaf4ef8e4a0b5ef3ecd312b5741443534459
parentb28fffb67f673397590038435c117189f95b6910 (diff)
downloadaur-2b68f105f653461e2065a561fbac281be94bc474.tar.gz
Fix Python module naming
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0e8f59f94e92..074b74bb4957 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = meme
pkgdesc = The MEME suite provides tools for discovering and using protein and DNA sequence motifs
pkgver = 5.0.4
- pkgrel = 2
+ pkgrel = 3
url = http://meme-suite.org/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index a451d0915e19..eb30b49d49ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
#Contributor: Charles E. Vejnar
pkgname=meme
pkgver=5.0.4
-pkgrel=2
+pkgrel=3
_minor=
pkgdesc="The MEME suite provides tools for discovering and using protein and DNA sequence motifs"
arch=("i686" "x86_64")
@@ -42,6 +42,12 @@ package() {
done
rmdir "${pkgdir}/usr/lib/meme-${pkgver}${_minor}/perl"
+ # Rename Python
+ for fname in $(ls -1 "${pkgdir}/usr/lib/meme-${pkgver}${_minor}/python"); do
+ if [[ $fname = meme-* ]]; then
+ mv "${pkgdir}/usr/lib/meme-${pkgver}${_minor}/python/${fname}" "${pkgdir}/usr/lib/meme-${pkgver}${_minor}/python/${fname#meme-}"
+ fi
+ done
sed -i -e "s/\(PROG => \)/\1'meme-'./g" "${pkgdir}/usr/bin/meme-meme-chip"