summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Schmidt2018-02-04 21:40:22 +0100
committerStefan Schmidt2018-02-04 21:40:22 +0100
commit2b6a3aa4931240888d835d1124b790a990fddd42 (patch)
treedf72bce84ef9741e728d9b2a171ad782236a69c2
parent5998021a3b68f5211eaffb0011bc8bfdb1789792 (diff)
downloadaur-2b6a3aa4931240888d835d1124b790a990fddd42.tar.gz
Fixed compilation
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
-rw-r--r--fix-compilation.patch11
3 files changed, 20 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b61736572e90..b429d923a55a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = powerpc-linux-gnu-gcc-stage2
pkgdesc = The GNU Compiler Collection. Stage 2 for toolchain building (powerpc-linux-gnu)
pkgver = 6.1.1
- pkgrel = 3
+ pkgrel = 4
url = http://gcc.gnu.org
arch = i686
arch = x86_64
@@ -21,7 +21,7 @@ pkgbase = powerpc-linux-gnu-gcc-stage2
options = !strip
source = https://github.com/gcc-mirror/gcc/archive/1bbd3999.tar.gz
source = http://isl.gforge.inria.fr/isl-0.16.1.tar.bz2
- md5sums = d4c4546f927b2984d66574b1b5cb817e
+ md5sums = ff2d7ad9a3144299decbdad85dfcb920
md5sums = ac1f25a0677912952718a51f5bc20f32
pkgname = powerpc-linux-gnu-gcc-stage2
diff --git a/PKGBUILD b/PKGBUILD
index 9fe566fb6e5a..2ff5c61da3ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ pkgname=${_target}-gcc-stage2
pkgver=6.1.1
_pkgver=6
_islver=0.16.1
-pkgrel=3
+pkgrel=4
_commit=1bbd3999
pkgdesc="The GNU Compiler Collection. Stage 2 for toolchain building (${_target})"
arch=('i686' 'x86_64')
@@ -23,12 +23,16 @@ replaces=("${_target}-gcc-stage1")
provides=("${_target}-gcc-stage1=${pkgver}")
source=(https://github.com/gcc-mirror/gcc/archive/${_commit}.tar.gz
http://isl.gforge.inria.fr/isl-${_islver}.tar.bz2)
-md5sums=('d4c4546f927b2984d66574b1b5cb817e'
+md5sums=('ff2d7ad9a3144299decbdad85dfcb920'
'ac1f25a0677912952718a51f5bc20f32')
prepare() {
mv gcc-${_commit}* gcc
- cd ${srcdir}/gcc
+ cd ${srcdir}
+
+ patch -Np0 < "../fix-compilation.patch"
+
+ cd gcc
# link isl for in-tree build
ln -s ../isl-${_islver} isl
diff --git a/fix-compilation.patch b/fix-compilation.patch
new file mode 100644
index 000000000000..f42abbd139ff
--- /dev/null
+++ b/fix-compilation.patch
@@ -0,0 +1,11 @@
+--- gcc/gcc/ubsan.c 2018-02-04 21:13:39.853992701 +0100
++++ gcc/gcc/ubsan.c 2018-02-04 21:12:44.957195790 +0100
+@@ -1469,7 +1469,7 @@
+
+ expanded_location xloc = expand_location (loc);
+ if (xloc.file == NULL || strncmp (xloc.file, "\1", 2) == 0
+- || xloc.file == '\0' || xloc.file[0] == '\xff'
++ || xloc.file[0] == '\0' || xloc.file[0] == '\xff'
+ || xloc.file[1] == '\xff')
+ return false;
+