summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Neumann2018-03-25 13:55:01 +0200
committerJan Neumann2018-03-25 13:55:01 +0200
commit2b96658b36355c4719b1337578f5e2c5acb9a234 (patch)
treec542fe493d5d89e42e67d3f5088bfbbb6b5911a9
parentfa2718c3ec76781622e884d5ec5052dc7edfd310 (diff)
downloadaur-2b96658b36355c4719b1337578f5e2c5acb9a234.tar.gz
add new theme
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD24
2 files changed, 22 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2b16362e93de..f4ff879ac3d2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = madkitas-plasma5-themes
pkgdesc = 3 nice looking plasma5 themes by Madkita
- pkgver = r24.cd544bd
+ pkgver = r41.dd58091
pkgrel = 1
- url = https://github.com/Madkita/Plasma-Themes.git
+ url = https://github.com/Madkita/Plasma-Themes
arch = any
license = GPL3
makedepends = git
depends = plasma-desktop
- source = madkitas-plasma5-themes-r24.cd544bd::git+https://github.com/Madkita/Plasma-Themes.git
+ source = git+https://github.com/Madkita/Plasma-Themes
sha256sums = SKIP
pkgname = plasma5-theme-aex-nomad-git
@@ -19,3 +19,6 @@ pkgname = plasma5-theme-breeze-noshadow-antu-git
pkgname = plasma5-theme-breeze-transparent-nomad-icons-git
pkgdesc = Breeze transparent theme with icons from nomad project
+pkgname = plasma5-theme-aex-nomad-dark-git
+ pkgdesc = Breeze transparent theme with icons from nomad project
+
diff --git a/PKGBUILD b/PKGBUILD
index 37cad7c6943e..fa7bfd30e4fd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,21 @@
# Maintainer: Jan Neumann <neum dot ja at gmail dot com>
pkgbase=madkitas-plasma5-themes
-pkgname=('plasma5-theme-aex-nomad-git' 'plasma5-theme-breeze-noshadow-antu-git' 'plasma5-theme-breeze-transparent-nomad-icons-git')
-pkgver=r24.cd544bd
+pkgname=('plasma5-theme-aex-nomad-git' 'plasma5-theme-breeze-noshadow-antu-git' 'plasma5-theme-breeze-transparent-nomad-icons-git' 'plasma5-theme-aex-nomad-dark-git')
+pkgver=r41.dd58091
pkgrel=1
pkgdesc="3 nice looking plasma5 themes by Madkita"
arch=('any')
-url='https://github.com/Madkita/Plasma-Themes.git'
+url='https://github.com/Madkita/Plasma-Themes'
license=('GPL3')
depends=('plasma-desktop')
makedepends=('git')
-source=("${pkgbase}-${pkgver}::git+${url}")
+source=("git+${url}")
sha256sums=('SKIP')
pkgver() {
- cd ${srcdir}/${pkgbase}-${pkgver}
+ cd ${srcdir}/Plasma-Themes
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
@@ -24,7 +24,7 @@ pkgver() {
package_plasma5-theme-aex-nomad-git() {
pkgdesc="Half transparent rounded corners shadowed macOS looking like theme"
- cd ${srcdir}/${pkgbase}-${pkgver}
+ cd ${srcdir}/Plasma-Themes
mkdir -p ${pkgdir}/usr/share/plasma/desktoptheme/Aex\ Nomad
cp -r Aex\ Nomad ${pkgdir}/usr/share/plasma/desktoptheme/
}
@@ -32,7 +32,7 @@ pkgdesc="Half transparent rounded corners shadowed macOS looking like theme"
package_plasma5-theme-breeze-noshadow-antu-git() {
pkgdesc="Default kde breeze theme without panel shadows and with icons from antu icon theme"
- cd ${srcdir}/${pkgbase}-${pkgver}
+ cd ${srcdir}/Plasma-Themes
mkdir -p ${pkgdir}/usr/share/plasma/desktoptheme/Breeze\ No\ shadow\ antu
cp -r Breeze\ No\ shadow\ antu ${pkgdir}/usr/share/plasma/desktoptheme/
}
@@ -40,7 +40,15 @@ pkgdesc="Default kde breeze theme without panel shadows and with icons from antu
package_plasma5-theme-breeze-transparent-nomad-icons-git() {
pkgdesc="Breeze transparent theme with icons from nomad project"
- cd ${srcdir}/${pkgbase}-${pkgver}
+ cd ${srcdir}/Plasma-Themes
mkdir -p ${pkgdir}/usr/share/plasma/desktoptheme/breeze\ transparent\ with\ nomad\ icons
cp -r breeze\ transparent\ with\ nomad\ icons ${pkgdir}/usr/share/plasma/desktoptheme/
}
+
+package_plasma5-theme-aex-nomad-dark-git() {
+pkgdesc="Breeze transparent theme with icons from nomad project"
+
+ cd ${srcdir}/Plasma-Themes
+ mkdir -p ${pkgdir}/usr/share/plasma/desktoptheme/Aex\ Nomad\ Dark
+ cp -r Aex\ Nomad\ Dark ${pkgdir}/usr/share/plasma/desktoptheme/
+}