summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Chain2017-04-18 10:50:13 +0200
committerGustavo Chain2017-04-18 10:50:13 +0200
commit2ba2a496a8b92f5b45f488f06ccdc804be454d3e (patch)
tree949cef40c8b31304572b71d827420b20a75cc04e
parent444000f765e202585435faef676591c3d0822f7d (diff)
downloadaur-2ba2a496a8b92f5b45f488f06ccdc804be454d3e.tar.gz
Get a release instead of build
-rw-r--r--PKGBUILD21
1 files changed, 8 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ea65b33c17dc..a909298d46f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,21 @@
# Maintainer: Gustavo Chain <gchain@gmail.com>
pkgname=httplab
-pkgver=0.1
+pkgver=0.2.1
pkgrel=2
pkgdesc="An interactive web server"
-arch=(any)
+arch=(x86_64)
url="http://github.com/gchaincl/httplab"
license=('MIT')
-makedepends=('go>=1.7')
+makedepends=('wget')
provides=('httplab=$pkgver')
conflicts=('httplab')
replaces=('httplab')
install=
-source=("$pkgname"::'git+https://github.com/gchaincl/httplab.git')
-md5sums=(SKIP)
-
-build() {
- export GOPATH=`pwd`/..
- cd "$pkgname"
- go build
-}
+source=("$pkgname"::'https://github.com/gchaincl/httplab/releases/download/v0.2.1/httplab_linux_amd64')
+md5sums=(
+ '6e1051b464963eb40e89a786ef9dcce8'
+)
package() {
- cd "$pkgname"
- install -D -s -m755 httplab "${pkgdir}/usr/bin/httplab"
+ install -D -s -m755 "httplab" "${pkgdir}/usr/bin/${pkgname}"
}