summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKagamma2021-09-23 02:16:14 +0700
committerKagamma2021-09-23 02:16:14 +0700
commit2ba4926d3cb0723af2d3ba48e9de19fc6e15996a (patch)
treeb9ecf74cb6baf9077ba68a6396a14e74c5c0aff9
parent8f5f42b89ed974f201ff2b6890ed18ae00744ff7 (diff)
downloadaur-2ba4926d3cb0723af2d3ba48e9de19fc6e15996a.tar.gz
Refactor code
-rw-r--r--PKGBUILD16
1 files changed, 4 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b39d99e4a65e..455a7983e205 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,24 @@
# Maintainer: Trung Le (Kagamma) <kagamma(dot)km(at)gmail(dot)com>
+
pkgname=castle-engine-git
pkgver=v7.0.alpha.1.r16494.f39aec48a
pkgrel=1
-epoch=
pkgdesc="Cross-platform (desktop, mobile, console) 3D and 2D game engine using modern Object Pascal"
arch=(x86_64)
url="https://castle-engine.io/"
license=('LGPL with static linking exception')
-groups=()
depends=(gtk2 freetype2 openal libpng libvorbis mesa)
makedepends=(git make fpc lazarus)
-checkdepends=()
optdepends=('fpc: to compile games'
'lazarus: to compile castle-editor')
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=()
-install=
-changelog=
source=(git+https://github.com/castle-engine/castle-engine.git)
-noextract=()
md5sums=('SKIP')
-validpgpkeys=()
+
pkgver() {
cd castle-engine
printf "%s.r%s.%s" "$(git describe --abbrev=0 | sed 's/\([^-]*-g\)/r\1/;s/-/./g')" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+
build() {
# Build tools
cd castle-engine
@@ -35,6 +26,7 @@ build() {
tools/build-tool/castle-engine --project tools/castle-editor compile
make cleanall
}
+
package() {
cd castle-engine
# Prepare desktop file