summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Cholasta2020-09-23 07:40:13 +0200
committerJan Cholasta2020-09-23 07:40:13 +0200
commit2ba53de3cd80a43e5dc0d160087dbfb8ca919aec (patch)
tree8ac9d8dfcd3a6537f8fa42c0613be3b8a040ad66
parentc479a6029df2d5b9df2cc8ef80c72f16be5d6d32 (diff)
downloadaur-2ba53de3cd80a43e5dc0d160087dbfb8ca919aec.tar.gz
raze-git-0.6.0+2041+g470f48161-1
-rw-r--r--.SRCINFO4
-rw-r--r--0001-Fix-file-paths.patch26
-rw-r--r--PKGBUILD4
3 files changed, 9 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b0156ba32f72..0c439ac8cf70 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = raze-git
pkgdesc = Build engine port backed by GZDoom tech (git version)
- pkgver = 0.6.0+485+g5330964a7
+ pkgver = 0.6.0+2041+g470f48161
pkgrel = 1
url = https://github.com/coelckers/Raze
arch = x86_64
@@ -26,7 +26,7 @@ pkgbase = raze-git
source = 0001-Fix-file-paths.patch
source = raze.desktop
sha256sums = SKIP
- sha256sums = 363b00bbc3022f584b93aaef704a192a5aa1cce2e72f295b2bf89ecce87050fd
+ sha256sums = dd4cb8fc741febe22375d87cc072a58afa3913022ecaea33e9f426cb1fa820c2
sha256sums = ffc02d8f6f0d4464a74e025d41063f2441d9423d4ed605a0290eb266ae9531c8
pkgname = raze-git
diff --git a/0001-Fix-file-paths.patch b/0001-Fix-file-paths.patch
index cc8b05379972..0ce76b272a0a 100644
--- a/0001-Fix-file-paths.patch
+++ b/0001-Fix-file-paths.patch
@@ -1,30 +1,14 @@
-From a8beb39ac0babaa9516a9888b35d1bfe657c0747 Mon Sep 17 00:00:00 2001
+From 8cde74c80be9fdfb0e00bb00b85b5bfed0e70da7 Mon Sep 17 00:00:00 2001
From: Jan Cholasta <jan@cholasta.net>
Date: Thu, 6 Feb 2020 07:59:18 +0100
Subject: [PATCH] Fix file paths
---
- source/common/audio/music/i_soundfont.cpp | 4 +---
source/common/platform/posix/sdl/i_main.cpp | 14 +-------------
source/core/gameconfigfile.cpp | 13 +------------
source/core/gamecontrol.cpp | 2 +-
- 4 files changed, 4 insertions(+), 29 deletions(-)
+ 3 files changed, 3 insertions(+), 26 deletions(-)
-diff --git a/source/common/audio/music/i_soundfont.cpp b/source/common/audio/music/i_soundfont.cpp
-index a8b4e9fdf..911b8e308 100644
---- a/source/common/audio/music/i_soundfont.cpp
-+++ b/source/common/audio/music/i_soundfont.cpp
-@@ -232,9 +232,7 @@ FPatchSetReader::FPatchSetReader(const char *filename)
- #ifndef _WIN32
- mCaseSensitivePaths = true;
- const char *paths[] = {
-- "/usr/local/lib/timidity",
-- "/etc/timidity",
-- "/etc"
-+ "/etc/timidity++"
- };
- #else
- const char *paths[] = {
diff --git a/source/common/platform/posix/sdl/i_main.cpp b/source/common/platform/posix/sdl/i_main.cpp
index 7fc179a51..fb4ce733e 100644
--- a/source/common/platform/posix/sdl/i_main.cpp
@@ -95,10 +79,10 @@ index b532b2925..8ffd663b1 100644
}
diff --git a/source/core/gamecontrol.cpp b/source/core/gamecontrol.cpp
-index 92b6c47ae..1d8bf338c 100644
+index cf89415e5..512577cf6 100644
--- a/source/core/gamecontrol.cpp
+++ b/source/core/gamecontrol.cpp
-@@ -749,7 +749,7 @@ int RunGame()
+@@ -826,7 +826,7 @@ int RunGame()
FString logfile = Args->TakeValue("+logfile");
// As long as this engine is still in prerelease mode let's always write a log file.
@@ -108,5 +92,5 @@ index 92b6c47ae..1d8bf338c 100644
if (logfile.IsNotEmpty())
{
--
-2.27.0
+2.28.0
diff --git a/PKGBUILD b/PKGBUILD
index 56e4f12c71db..79ee8831598b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jan Cholasta <grubber at grubber cz>
pkgname=raze-git
-pkgver=0.6.0+485+g5330964a7
+pkgver=0.6.0+2041+g470f48161
pkgrel=1
pkgdesc='Build engine port backed by GZDoom tech (git version)'
arch=('x86_64')
@@ -27,7 +27,7 @@ source=("Raze::git+https://github.com/coelckers/Raze"
'0001-Fix-file-paths.patch'
'raze.desktop')
sha256sums=('SKIP'
- '363b00bbc3022f584b93aaef704a192a5aa1cce2e72f295b2bf89ecce87050fd'
+ 'dd4cb8fc741febe22375d87cc072a58afa3913022ecaea33e9f426cb1fa820c2'
'ffc02d8f6f0d4464a74e025d41063f2441d9423d4ed605a0290eb266ae9531c8')
pkgver() {