summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax G2021-01-13 20:25:42 +0200
committerMax G2021-01-13 20:25:42 +0200
commit2bb2f531838014a7b3e70c2c12f30275aada940d (patch)
tree52eef6c7b670a8c9a409dcf569619e80ca8e4ad2
parentda18abe2b8c9cdf773b384d592525aee20c17f54 (diff)
downloadaur-2bb2f531838014a7b3e70c2c12f30275aada940d.tar.gz
"Updated to v0.8.4"
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD10
2 files changed, 18 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ac639ad0a540..f99eac484469 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,25 @@
pkgbase = python-aur-deploy
pkgdesc = Automate updating pkgbuild and deploying to AUR
- pkgver = 0.8.2
+ pkgver = 0.8.4
pkgrel = 1
url = https://github.com/codeswhite/aur-deploy
arch = any
license = MIT
makedepends = python-setuptools
- makedepends = python-interutils
- makedepends = python-requests
- makedepends = python-beautifulsoup4
- makedepends = pip2pkgbuild
depends = python
- source = https://files.pythonhosted.org/packages/source/a/aur-deploy/aur-deploy-0.8.2.tar.gz
- sha256sums = 1ed5998565077b389be645f5cd7b4e199833a7cf7bb8173d586267ff4384d950
+ depends = twine
+ depends = python-wheel
+ depends = python-beautifulsoup4
+ depends = pip2pkgbuild
+ depends = python-interutils
+ source = https://files.pythonhosted.org/packages/source/a/aur-deploy/aur-deploy-0.8.4.tar.gz
+ sha256sums = 18bc94489b553e70b080a8542cc5df3585b9ac5ca6e8e6e4f7cbe26bcbd32472
pkgname = python-aur-deploy
depends = python
+ depends = twine
+ depends = python-wheel
+ depends = python-beautifulsoup4
+ depends = pip2pkgbuild
+ depends = python-interutils
diff --git a/PKGBUILD b/PKGBUILD
index 92f454325d1c..26bd99425325 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
pkgbase='python-aur-deploy'
pkgname=('python-aur-deploy')
_module='aur-deploy'
-pkgver=0.8.2
+pkgver=0.8.4
pkgrel=1
pkgdesc="Automate updating pkgbuild and deploying to AUR"
url="https://github.com/codeswhite/aur-deploy"
-depends=('python')
-makedepends=('python-setuptools' 'python-interutils' 'python-requests' 'python-beautifulsoup4' 'pip2pkgbuild')
+makedepends=('python-setuptools')
+depends=('python' 'twine' 'python-wheel' 'python-beautifulsoup4' 'pip2pkgbuild' 'python-interutils')
license=('MIT')
arch=('any')
-source=("https://files.pythonhosted.org/packages/source/a/aur-deploy/aur-deploy-${pkgver}.tar.gz")
-sha256sums=("1ed5998565077b389be645f5cd7b4e199833a7cf7bb8173d586267ff4384d950")
+source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
+sha256sums=("18bc94489b553e70b080a8542cc5df3585b9ac5ca6e8e6e4f7cbe26bcbd32472")
build() {
cd "${srcdir}/${_module}-${pkgver}"