summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordangersalad2022-06-27 11:52:22 -0600
committerdangersalad2022-06-27 11:52:22 -0600
commit2bb85ccd6d6821e35f4a774583a149526a5865e0 (patch)
treee3d2e2c01535933786c726d14c25ade72ee7d7be
parent0f6840efcd9b633d4fb0818829fdeeea3aceda43 (diff)
downloadaur-2bb85ccd6d6821e35f4a774583a149526a5865e0.tar.gz
add launcher and desktop entry for megameklab
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD12
-rw-r--r--megameklab.desktop9
-rw-r--r--megameklab.sh19
5 files changed, 43 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a6c0b261088e..f7c8f1ee1591 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mekhq
pkgdesc = MekHQ is a java helper program for the MegaMek game that allows users to load a list of entities from an XML file, perform repairs and customizations, and then save the new entities to another XML file that can be loaded into MegaMek.
pkgver = 0.48.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/MegaMek/mekhq
arch = x86_64
license = GPL
@@ -15,14 +15,18 @@ pkgbase = mekhq
source = megameklab.tar.gz::https://github.com/MegaMek/megameklab/archive/refs/tags/v0.48.0.tar.gz
source = mekhq.desktop
source = megamek.desktop
+ source = megameklab.desktop
source = mekhq.sh
source = megamek.sh
+ source = megameklab.sh
sha256sums = 69bee526358f576453b51fae8ef2c3aa83f09c044d032f6c587c4fe267b9d2ba
sha256sums = 4942182c885b87caa9e851d1851add095f2e2103c0933b61e961f6e74d3e1b29
sha256sums = e7b0e37d98cd8273d7e23ce655773c37482980f4d2a95d739e1f8af025e0989f
sha256sums = a6c0cc72c6f3ad773bdcec24c8036ae7d09dcaea4908f5b6d4e5ac6091cff772
sha256sums = caf5bf3e7294029c7b6dec974eed0253d6caf3804a6a9fcc953edc3c9be98b16
+ sha256sums = 6e6bb03f14a0ce6e06fd9009fd9f159d22a34a7020ba85b13ad6dbf649ca9e38
sha256sums = fda6e9d542062041e9d9b7f6331069d8a78b9455a290286aa8d214ed66b13fd7
sha256sums = 9ad4d0251ecfe02140c46dfeb67a4ce2b0fe9f123b04a3911139b8e255ff2beb
+ sha256sums = b0011b6437b2209de29875f5d805bd74b006174b8cf1f4a5d700bb4191986214
pkgname = mekhq
diff --git a/.gitignore b/.gitignore
index 5fdc46c8c82d..6b358cd3d816 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
-*.pkg.tar.xz
+*.pkg.tar.*
*.tar.gz
/pkg
/src
diff --git a/PKGBUILD b/PKGBUILD
index ff14d56065b6..5a2c3ca93fd3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=mekhq
pkgver=0.48.0
_pkgver=
-pkgrel=2
+pkgrel=3
epoch=
pkgdesc="MekHQ is a java helper program for the MegaMek game that allows users to load a list of entities from an XML file, perform repairs and customizations, and then save the new entities to another XML file that can be loaded into MegaMek."
@@ -20,16 +20,20 @@ source=("mekhq.tar.gz::https://github.com/MegaMek/mekhq/archive/refs/tags/v${pkg
"megameklab.tar.gz::https://github.com/MegaMek/megameklab/archive/refs/tags/v${pkgver}.tar.gz"
"mekhq.desktop"
"megamek.desktop"
+ "megameklab.desktop"
"mekhq.sh"
- "megamek.sh")
+ "megamek.sh"
+ "megameklab.sh")
sha256sums=('69bee526358f576453b51fae8ef2c3aa83f09c044d032f6c587c4fe267b9d2ba'
'4942182c885b87caa9e851d1851add095f2e2103c0933b61e961f6e74d3e1b29'
'e7b0e37d98cd8273d7e23ce655773c37482980f4d2a95d739e1f8af025e0989f'
'a6c0cc72c6f3ad773bdcec24c8036ae7d09dcaea4908f5b6d4e5ac6091cff772'
'caf5bf3e7294029c7b6dec974eed0253d6caf3804a6a9fcc953edc3c9be98b16'
+ '6e6bb03f14a0ce6e06fd9009fd9f159d22a34a7020ba85b13ad6dbf649ca9e38'
'fda6e9d542062041e9d9b7f6331069d8a78b9455a290286aa8d214ed66b13fd7'
- '9ad4d0251ecfe02140c46dfeb67a4ce2b0fe9f123b04a3911139b8e255ff2beb')
+ '9ad4d0251ecfe02140c46dfeb67a4ce2b0fe9f123b04a3911139b8e255ff2beb'
+ 'b0011b6437b2209de29875f5d805bd74b006174b8cf1f4a5d700bb4191986214')
build() {
rm -rf megamek megameklab
@@ -79,8 +83,10 @@ package() {
install -D mekhq.desktop "${pkgdir}/usr/share/applications/${pkgname}.desktop"
install -D megamek.desktop "${pkgdir}/usr/share/applications/megamek.desktop"
+ install -D megameklab.desktop "${pkgdir}/usr/share/applications/megameklab.desktop"
install -Dm755 mekhq.sh "${pkgdir}/usr/bin/${pkgname}"
install -Dm755 megamek.sh "${pkgdir}/usr/bin/megamek"
+ install -Dm755 megameklab.sh "${pkgdir}/usr/bin/megameklab"
}
diff --git a/megameklab.desktop b/megameklab.desktop
new file mode 100644
index 000000000000..4ef71aa2bb5d
--- /dev/null
+++ b/megameklab.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=MegaMek Lab
+GenericName=Java version of BattleTech (Mek Editor)
+Exec=megameklab
+Terminal=false
+Type=Application
+Icon=megameklab
+Categories=Games;Java;
+StartupWMClass=SWT
diff --git a/megameklab.sh b/megameklab.sh
new file mode 100644
index 000000000000..593a9c897fcc
--- /dev/null
+++ b/megameklab.sh
@@ -0,0 +1,19 @@
+#!/usr/bin/env bash
+
+conf=$HOME/.config/mekhq
+
+if [[ -n "$XGD_CONFIG_HOME" ]]
+then
+ conf="$XDG_CONFIG_HOME/mekhq"
+fi
+
+if [[ ! -d "$conf" ]]
+then
+ mkdir -p "$conf"
+fi
+
+rsync -avc /usr/lib/mekhq/ "$conf/"
+
+cd "$conf"
+
+exec env MEGAMEK_CONFPATH="$conf" "$conf/lab"