summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorclintval2018-01-21 17:57:47 -0800
committerclintval2018-01-21 17:57:47 -0800
commit2bb9bf30a59dd4d04d3c8ca86cc18c10b38dd237 (patch)
tree7d53b2c3eb524332ede1cc444064c1c420a2dd26
parent606c2689205f6d9f0340536d9595f95ab5200a70 (diff)
downloadaur-2bb9bf30a59dd4d04d3c8ca86cc18c10b38dd237.tar.gz
python-pydna to split package
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD91
2 files changed, 82 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0a4504963290..9111cff16058 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,29 +1,28 @@
pkgbase = python-pydna
pkgdesc = Python3 classes for dsDNA simulation of homologous recombination, Gibson assembly and interactive cloning
- pkgver = 2.0.1
- pkgrel = 2
- url = https://github.com/BjornFJohansson/pydna
+ pkgver = 2.0.3
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/pydna
arch = any
- license = MIT
+ license = GPL3
+ makedepends = python
makedepends = python-setuptools
+ options = !emptydirs
+ source = python-pydna-2.0.3.zip::https://pypi.python.org/packages/67/f2/552bd375666bb3e2ff4b3ec418ed2d5bbe1140847075d7c2d682435153c8/pydna-2.0.3.zip
+ sha256sums = 64b49daf4e30c53ac45a0bb5f40519fc627dd01c5751eae9d72a8f4a75a19e16
+
+pkgname = python-pydna
depends = python
- depends = python-appdirs>=1.3.0
- depends = python-biopython>=1.65
- depends = python-networkx>=1.8.1
- depends = python-ordered-set>=2.0.2
- depends = python-prettytable>=0.7.2
- depends = python-pyparsing>=2.1.10
+ depends = python-appdirs
+ depends = python-biopython
+ depends = python-networkx
+ depends = python-ordered-set
+ depends = python-prettytable
+ depends = python-pyparsing
depends = python-requests
optdepends = python-matplotlib: gel simulation
optdepends = python-mpldatacursor: gel simulation
optdepends = python-numpy: gel simulation
- optdepends = python-pint>=0.7.2: gel simulation
+ optdepends = python-pint: gel simulation
optdepends = python-scipy: gel simulation
- provides = python-pydna
- conflicts = python-pydna
- options = !emptydirs
- source = https://github.com/BjornFJohansson/pydna/archive/2.0.1.tar.gz
- md5sums = 92a7fa5be11350dcf8d652d74f8c1762
-
-pkgname = python-pydna
diff --git a/PKGBUILD b/PKGBUILD
index 36069b3e7ee2..98f2262a6438 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,76 @@
# Maintainer: Clint Valentine <valentine.clint@gmail.com>
-pkgname='python-pydna'
-pkgver=2.0.1
-pkgrel=2
+_name=pydna
+pkgbase='python-pydna'
+pkgname=('python-pydna')
+pkgver=2.0.3
+pkgrel=1
pkgdesc="Python3 classes for dsDNA simulation of homologous recombination, Gibson assembly and interactive cloning"
arch=('any')
-url="https://github.com/BjornFJohansson/pydna"
-license=('MIT')
-depends=(
- 'python'
- 'python-appdirs>=1.3.0'
- 'python-biopython>=1.65'
- 'python-networkx>=1.8.1'
- 'python-ordered-set>=2.0.2'
- 'python-prettytable>=0.7.2'
- 'python-pyparsing>=2.1.10'
- 'python-requests'
+url="https://pypi.python.org/pypi/pydna"
+license=('GPL3')
+makedepends=(
+ 'python' 'python-setuptools'
+ # 'python2' 'python2-setuptools'
)
-makedepends=('python-setuptools')
-optdepends=(
+options=(!emptydirs)
+source=("${pkgname}"-"${pkgver}".zip::https://pypi.python.org/packages/67/f2/552bd375666bb3e2ff4b3ec418ed2d5bbe1140847075d7c2d682435153c8/pydna-2.0.3.zip)
+sha256sums=('64b49daf4e30c53ac45a0bb5f40519fc627dd01c5751eae9d72a8f4a75a19e16')
+
+# prepare() {
+# cp -a "${_name}"-"${pkgver}"{,-py2}
+# }
+
+build(){
+ cd "${srcdir}"/"${_name}"-"${pkgver}"
+ python setup.py build
+
+ # cd "${srcdir}"/"${_name}"-"${pkgver}"-py2
+ # python2 setup.py build
+}
+
+package_python2-pydna() {
+ depends=(
+ 'python2'
+ 'python2-appdirs'
+ 'python2-biopython'
+ 'python2-networkx'
+ 'python2-ordered-set'
+ 'python2-prettytable'
+ 'python2-pyparsing'
+ 'python2-requests'
+ )
+ optdepends=(
+ 'python2-matplotlib: gel simulation'
+ 'python2-mpldatacursor: gel simulation'
+ 'python2-numpy: gel simulation'
+ 'python2-pint: gel simulation'
+ 'python2-scipy: gel simulation'
+ )
+
+ cd "${_name}"-"${pkgver}"-py2
+ python2 setup.py install --root="${pkgdir}"/ --optimize=1 --skip-build
+}
+
+package_python-pydna() {
+ depends=(
+ 'python'
+ 'python-appdirs'
+ 'python-biopython'
+ 'python-networkx'
+ 'python-ordered-set'
+ 'python-prettytable'
+ 'python-pyparsing'
+ 'python-requests'
+ )
+ optdepends=(
'python-matplotlib: gel simulation'
'python-mpldatacursor: gel simulation'
'python-numpy: gel simulation'
- 'python-pint>=0.7.2: gel simulation'
+ 'python-pint: gel simulation'
'python-scipy: gel simulation'
-)
-provides=('python-pydna')
-conflicts=('python-pydna')
-options=(!emptydirs)
-source=("https://github.com/BjornFJohansson/pydna/archive/${pkgver}.tar.gz")
-md5sums=('92a7fa5be11350dcf8d652d74f8c1762')
+ )
-package() {
- cd "${srcdir}/pydna-${pkgver}"
- python setup.py install --root="${pkgdir}/" --optimize=1
+ cd "${_name}"-"${pkgver}"
+ python setup.py install --root="${pkgdir}"/ --optimize=1 --skip-build
}