summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGordian Edenhofer2021-04-06 11:00:34 +0200
committerGordian Edenhofer2021-04-06 11:00:34 +0200
commit2be3693a277ad027e7f132ae9aff88efb4ebda1d (patch)
tree62d07c88954de676acbdcfd9b7a635c8fe92769e
parent4ef4e9abfdfae65714b81bbe12ee6baa1ca33116 (diff)
downloadaur-2be3693a277ad027e7f132ae9aff88efb4ebda1d.tar.gz
upgpkg: python-gensim 4.0.1-1
Add 'python-pip' to the list of make-dependencies as it is explicitly called before compilation even though it is not listed in the setup.py script as dependency.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dac570f388d1..97fb3f83adf2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-gensim
pkgdesc = Library for topic modelling, document indexing and similarity retrieval with large corpora
- pkgver = 4.0.0
+ pkgver = 4.0.1
pkgrel = 1
url = https://radimrehurek.com/gensim/
arch = i686
@@ -8,12 +8,13 @@ pkgbase = python-gensim
license = LGPL2.1
makedepends = python-setuptools
makedepends = python-wheel
+ makedepends = python-pip
makedepends = cython
depends = python-numpy
depends = python-scipy
depends = python-smart_open
optdepends = python-pyro: Usage in a distributed environment
- source = python-gensim-4.0.0.tar.gz::https://github.com/RaRe-Technologies/gensim/archive/4.0.0.tar.gz
- sha512sums = 64bdee7d5f60b0cb158fbd628fd13cfa8f266da5b43202a4a179f778c1f93cfe35cb484c860e104f8b73f57bcd26052de136f180d5543a33134a5617d3cf6adf
+ source = python-gensim-4.0.1.tar.gz::https://github.com/RaRe-Technologies/gensim/archive/4.0.1.tar.gz
+ sha512sums = 50ce30193a4356b5f708ce77c9dec9d1d209c904732e1982d62494bba9ee6d371f9df32a830883567e0e4b7ca575442248d510f395a964965e0d2352861323df
pkgname = python-gensim
diff --git a/PKGBUILD b/PKGBUILD
index 230fbfc91dc1..b08a552f04d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=python-gensim
_pkgname=gensim
-pkgver=4.0.0
+pkgver=4.0.1
pkgrel=1
pkgdesc="Library for topic modelling, document indexing and similarity retrieval with large corpora"
arch=('i686' 'x86_64')
@@ -13,9 +13,9 @@ license=('LGPL2.1')
url="https://radimrehurek.com/gensim/"
depends=('python-numpy' 'python-scipy' 'python-smart_open')
optdepends=("python-pyro: Usage in a distributed environment")
-makedepends=('python-setuptools' 'python-wheel' 'cython')
+makedepends=('python-setuptools' 'python-wheel' 'python-pip' 'cython')
source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/RaRe-Technologies/${_pkgname}/archive/${pkgver}.tar.gz")
-sha512sums=('64bdee7d5f60b0cb158fbd628fd13cfa8f266da5b43202a4a179f778c1f93cfe35cb484c860e104f8b73f57bcd26052de136f180d5543a33134a5617d3cf6adf')
+sha512sums=('50ce30193a4356b5f708ce77c9dec9d1d209c904732e1982d62494bba9ee6d371f9df32a830883567e0e4b7ca575442248d510f395a964965e0d2352861323df')
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"