summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2023-05-27 19:06:11 +0200
committerFabioLolix2023-05-27 19:06:11 +0200
commit2bf9121a142af4460768ab03e03944360b36239b (patch)
tree993b1fa4575253070896cac31868cb28a4b5b2d3
parentf323b47fc7aa362cba719ecb8c412acbf27e529d (diff)
downloadaur-2bf9121a142af4460768ab03e03944360b36239b.tar.gz
revision
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD53
2 files changed, 40 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1d72c82eb839..d063453dda53 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,17 @@
-# Generated by mksrcinfo v8
-# Fri Oct 14 12:52:59 UTC 2016
pkgbase = libxmp-git
pkgdesc = Library that supports over 90 module formats (Amiga, Atari, ..)
- pkgver = libxmp.4.4.1.r3.gf573488
- pkgrel = 1
- url = http://xmp.sourceforge.net/
- arch = i686
+ pkgver = 4.5.0.r758.g2e008819
+ pkgrel = 2
+ url = https://xmp.sourceforge.net/
arch = x86_64
- license = GPL
+ arch = aarch64
+ license = LGPL2.1
makedepends = git
depends = glibc
- optdepends = pulseaudio
provides = libxmp
conflicts = libxmp
- source = libxmp-git::git+https://github.com/cmatsuoka/libxmp.git
- md5sums = SKIP
+ options = !emptydirs
+ source = git+https://github.com/cmatsuoka/libxmp.git
+ sha256sums = SKIP
pkgname = libxmp-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 336108bee448..b1294db62610 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,43 @@
-# Maintainer: Chromaryu <knight.ryu12@gmail.com>
+# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
+# Contributor: Chromaryu <knight.ryu12@gmail.com>
+
pkgname=libxmp-git
-pkgver=libxmp.4.4.1.r3.gf573488
-pkgrel=1
+pkgver=4.5.0.r758.g2e008819
+pkgrel=2
pkgdesc="Library that supports over 90 module formats (Amiga, Atari, ..)"
-arch=('i686' 'x86_64')
-url="http://xmp.sourceforge.net/"
-license=('GPL')
-depends=('glibc')
-optdepends=('pulseaudio')
-makedepends=('git')
-conflicts=('libxmp')
-provides=('libxmp')
-source=("$pkgname"::"git+https://github.com/cmatsuoka/libxmp.git")
-md5sums=('SKIP')
+arch=(x86_64 aarch64)
+url="https://xmp.sourceforge.net/"
+license=(LGPL2.1)
+depends=(glibc)
+makedepends=(git)
+conflicts=(libxmp)
+provides=(libxmp)
+options=(!emptydirs)
+source=("git+https://github.com/cmatsuoka/libxmp.git")
+sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/$pkgname"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd libxmp
+ git describe --long --tags | sed 's/^libxmp-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd libxmp
+ autoconf
}
build() {
- cd "$srcdir/$pkgname"
- autoconf
- ./configure --prefix=/usr
- make
+ cd libxmp
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd libxmp
+ make -k check
}
package() {
- cd "$srcdir/$pkgname"
- make DESTDIR="$pkgdir" install
+ cd libxmp
+ make DESTDIR="${pkgdir}" install
}