summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-08-18 01:58:44 -0500
committerLuis Martinez2021-08-18 01:58:44 -0500
commit2c00d2b50df6d42a2a3cbdb2fe6a3b8174a8a17e (patch)
tree3d6bfabf2afe4b84bb63489d55d2276840ade18d
downloadaur-2c00d2b50df6d42a2a3cbdb2fe6a3b8174a8a17e.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD30
-rw-r--r--nebulous.install4
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7a61ba2bb707
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = neovim-nebulous-git
+ pkgdesc = Minimalist collection of colorschemes
+ pkgver = r38.b15c938
+ pkgrel = 1
+ url = https://github.com/yagua/nebulous.nvim
+ install = nebulous.install
+ arch = any
+ groups = neovim-plugins
+ license = MIT
+ makedepends = git
+ depends = neovim>=0.5
+ optdepends = tree-sitter
+ provides = neovim-nebulous
+ conflicts = neovim-nebulous
+ source = neovim-nebulous-git::git+https://github.com/yagua/nebulous.nvim
+ md5sums = SKIP
+
+pkgname = neovim-nebulous-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7248f5762598
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+
+pkgname=neovim-nebulous-git
+pkgver=r38.b15c938
+pkgrel=1
+pkgdesc="Minimalist collection of colorschemes"
+arch=('any')
+url="https://github.com/yagua/nebulous.nvim"
+license=('MIT')
+groups=('neovim-plugins')
+depends=('neovim>=0.5')
+optdepends=('tree-sitter')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+install=nebulous.install
+source=("$pkgname::git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname"
+ find colors lua -type f -exec install -Dm 644 '{}' "$pkgdir/usr/share/nvim/runtime/{}" \;
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}
diff --git a/nebulous.install b/nebulous.install
new file mode 100644
index 000000000000..9da74225e29d
--- /dev/null
+++ b/nebulous.install
@@ -0,0 +1,4 @@
+post_install() {
+ echo ':: This plugin requires manual setup.'
+ echo ':: Please refer to the installed README under /usr/share/doc/neovim-nebulous-git/README.md for more information.'
+}