summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2023-05-05 09:06:01 -0400
committerGuillaume Horel2023-05-05 09:06:01 -0400
commit2c0339ca5b6d5ab4a499743f488d02f983b63646 (patch)
tree755e8f5186731f00441f690413ef592eb1e1548a
parent85f4301b1496ce4ed4879753681377776cea2db1 (diff)
downloadaur-2c0339ca5b6d5ab4a499743f488d02f983b63646.tar.gz
bump to 2.7.4
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c7cad3fcb38a..d5c32f3051bc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,20 @@
pkgbase = python-fpdf2
pkgdesc = Simple PDF generation for Python
- pkgver = 2.7.3
+ pkgver = 2.7.4
pkgrel = 1
url = https://pyfpdf.github.io/fpdf2/
arch = any
license = LGPL3
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
+ makedepends = python-wheel
depends = python
depends = python-pillow
depends = python-defusedxml
depends = python-fonttools
conflicts = python-fpdf
- source = https://files.pythonhosted.org/packages/source/f/fpdf2/fpdf2-2.7.3.tar.gz
- sha256sums = 5e53fd440b1b6dc24a33f5c12d05bc349f923a78f50e2ecb2f0b876b55182c41
+ source = https://files.pythonhosted.org/packages/source/f/fpdf2/fpdf2-2.7.4.tar.gz
+ sha256sums = b2b7197610a83dd6fe96c3b91a633827acc74973b4290103617d371d0d0a8ecf
pkgname = python-fpdf2
diff --git a/PKGBUILD b/PKGBUILD
index af5f8a88c88a..d48153574eab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
pkgname=python-fpdf2
_name=${pkgname#python-}
-pkgver=2.7.3
+pkgver=2.7.4
pkgrel=1
pkgdesc='Simple PDF generation for Python'
arch=(any)
@@ -9,16 +9,16 @@ url='https://pyfpdf.github.io/fpdf2/'
license=(LGPL3)
conflicts=('python-fpdf')
depends=('python' 'python-pillow' 'python-defusedxml' 'python-fonttools')
-makedepends=('python-setuptools')
+makedepends=(python-build python-installer python-setuptools python-wheel)
source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
-sha256sums=('5e53fd440b1b6dc24a33f5c12d05bc349f923a78f50e2ecb2f0b876b55182c41')
+sha256sums=('b2b7197610a83dd6fe96c3b91a633827acc74973b4290103617d371d0d0a8ecf')
build() {
cd "$_name-$pkgver"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "$_name-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
}