summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2019-08-05 17:49:22 -0400
committerSolomon Choina2019-08-05 17:49:22 -0400
commit2c493c36d5f21b2d5e45fb300765e5d675101db3 (patch)
treea7149677ffcab1ba9de2e449bc2ddeaf2ed45f86
parent81cd0b4f1119acbfc8591aa437bb83841c02e0dc (diff)
downloadaur-2c493c36d5f21b2d5e45fb300765e5d675101db3.tar.gz
hopefully this'll be the final set of 3.2.1'
-rw-r--r--.SRCINFO16
-rw-r--r--0001-will-hopefully-work.patch25
-rw-r--r--PKGBUILD21
-rw-r--r--xmonad.hs.example19
4 files changed, 64 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ab7ea8820f9b..ee14526a77ab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = taffybar
pkgdesc = A desktop bar similar to xmobar, but with more GUI
pkgver = 3.2.1
- pkgrel = 1
+ pkgrel = 2
url = http://github.com/travitch/taffybar
install = taffybar.install
arch = i686
@@ -12,17 +12,20 @@ pkgbase = taffybar
depends = haskell-alsa-mixer
depends = haskell-configfile
depends = haskell-either
+ depends = haskell-gi-pango
+ depends = haskell-broadcast-chan
+ depends = haskell-http-client
+ depends = haskell-http-types
+ depends = haskell-http-client-tls
depends = haskell-gi-cairo-connector
depends = haskell-gi-cairo-render
depends = haskell-hstringtemplate
depends = haskell-http
depends = haskell-x11
+ depends = haskell-scotty
depends = haskell-dyre
- depends = haskell-gtk
- depends = haskell-gtk-traymanager
depends = haskell-enclosed-exceptions
depends = haskell-dbus
- depends = haskell-mtl
depends = haskell-multimap
depends = haskell-network
depends = haskell-network-uri
@@ -43,7 +46,6 @@ pkgbase = taffybar
depends = haskell-dbus-hslogger
depends = haskell-xml-helpers
depends = haskell-status-notifier-item
- depends = haskell-gi-gobject
depends = haskell-gi-gdkx11
depends = haskell-gi-gtk
depends = haskell-gtk-strut
@@ -53,16 +55,16 @@ pkgbase = taffybar
depends = xmonad-contrib
source = https://github.com/taffybar/taffybar/archive/v3.2.1.tar.gz
source = dynamic-compilation.patch
+ source = 0001-will-hopefully-work.patch
source = taffybar.install
source = taffybar.service
source = https://raw.githubusercontent.com/taffybar/taffybar/13b32fc2bc62129093494e939339a979d641691c/xmonad.hs.example
- source = https://github.com/taffybar/taffybar/commit/ee2cd6b871ea05bc60a050d5cefc9e307475e794.patch
sha256sums = 51ca3f4dd505a9d5fb03a3150898bcd090e037ca851f04a4ce4185135bf537ca
sha256sums = ff90b6e3d05b3bb94cfc2365708bbabbb96fd9a9a4919c0face6f8d2b69037e7
+ sha256sums = 80a3eba5861ec0d92e0b4e5ebdd7b7c0797695c5f997ca9d329e53eee02508f0
sha256sums = e1a1c820057c64fab4521de3c9b153e4d54e7df9a96d94679dbffc9cec245076
sha256sums = f4a08e887ba527a24f4cecc22393023bf7230172cc76f840ddfc5cfc54182a7e
sha256sums = 1a8ca4f177891941960585e228d5386ea9f120a1bb12ac0a956200de839032cb
- sha256sums = 697275116d1a11410326dc40d9bc8d712f51f9c156b5ff241fb681b79a5ffb18
pkgname = taffybar
diff --git a/0001-will-hopefully-work.patch b/0001-will-hopefully-work.patch
new file mode 100644
index 000000000000..cfd9e9306c47
--- /dev/null
+++ b/0001-will-hopefully-work.patch
@@ -0,0 +1,25 @@
+From 04184c6077d2d28db0c383a5c271f5b1bfd30d98 Mon Sep 17 00:00:00 2001
+From: Solomon Choina <shlomochoina@gmail.com>
+Date: Mon, 5 Aug 2019 09:14:49 -0400
+Subject: [PATCH] will hopefully work
+
+---
+ taffybar.cabal | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/taffybar.cabal b/taffybar.cabal
+index 4b7521c..0b9066b 100644
+--- a/taffybar.cabal
++++ b/taffybar.cabal
+@@ -43,7 +43,7 @@ library
+ , HStringTemplate >= 0.8 && < 0.9
+ , X11 >= 1.5.0.1
+ , ansi-terminal
+- , broadcast-chan >= 0.2.0.2
++ , broadcast-chan
+ , bytestring
+ , containers
+ , dbus >= 1.2.1 && < 2.0.0
+--
+2.22.0
+
diff --git a/PKGBUILD b/PKGBUILD
index 5ecb427878b6..e4143bf5fbef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Leif Warner <abimelech@gmail.com>
pkgname=taffybar
pkgver=3.2.1
-pkgrel=1
+pkgrel=2
license=('BSD3')
pkgdesc="A desktop bar similar to xmobar, but with more GUI"
url="http://github.com/travitch/taffybar"
@@ -11,17 +11,20 @@ depends=("ghc-libs"
"haskell-alsa-mixer"
"haskell-configfile"
"haskell-either"
+ "haskell-gi-pango"
+ "haskell-broadcast-chan"
+ "haskell-http-client"
+ "haskell-http-types"
+ "haskell-http-client-tls"
"haskell-gi-cairo-connector"
"haskell-gi-cairo-render"
"haskell-hstringtemplate"
"haskell-http"
"haskell-x11"
+ "haskell-scotty"
"haskell-dyre"
- "haskell-gtk"
- "haskell-gtk-traymanager"
"haskell-enclosed-exceptions"
"haskell-dbus"
- "haskell-mtl"
"haskell-multimap"
"haskell-network"
"haskell-network-uri"
@@ -42,7 +45,6 @@ depends=("ghc-libs"
"haskell-dbus-hslogger"
"haskell-xml-helpers"
"haskell-status-notifier-item"
- "haskell-gi-gobject"
"haskell-gi-gdkx11"
"haskell-gi-gtk"
"haskell-gtk-strut"
@@ -54,18 +56,18 @@ makedepends=('ghc')
install=taffybar.install
source=("https://github.com/taffybar/taffybar/archive/v${pkgver}.tar.gz"
"dynamic-compilation.patch"
+ "0001-will-hopefully-work.patch"
"taffybar.install"
"taffybar.service"
"https://raw.githubusercontent.com/taffybar/taffybar/13b32fc2bc62129093494e939339a979d641691c/xmonad.hs.example"
- "https://github.com/taffybar/taffybar/commit/ee2cd6b871ea05bc60a050d5cefc9e307475e794.patch"
)
sha256sums=('51ca3f4dd505a9d5fb03a3150898bcd090e037ca851f04a4ce4185135bf537ca'
'ff90b6e3d05b3bb94cfc2365708bbabbb96fd9a9a4919c0face6f8d2b69037e7'
+ '80a3eba5861ec0d92e0b4e5ebdd7b7c0797695c5f997ca9d329e53eee02508f0'
'e1a1c820057c64fab4521de3c9b153e4d54e7df9a96d94679dbffc9cec245076'
'f4a08e887ba527a24f4cecc22393023bf7230172cc76f840ddfc5cfc54182a7e'
- '1a8ca4f177891941960585e228d5386ea9f120a1bb12ac0a956200de839032cb'
- '697275116d1a11410326dc40d9bc8d712f51f9c156b5ff241fb681b79a5ffb18')
+ '1a8ca4f177891941960585e228d5386ea9f120a1bb12ac0a956200de839032cb')
# PKGBUILD functions
@@ -75,7 +77,6 @@ prepare() {
# See https://github.com/willdonnelly/dyre/issues/5
#sed -i -e 's/Dyre.ghcOpts = \["-threaded", "-rtsopts"\]/Dyre.ghcOpts = \["-threaded", "-rtsopts", "-dynamic"\]/' src/System/Taffybar.hs
patch -p1 -i ../dynamic-compilation.patch
- patch -p1 -i ../ee2cd6b871ea05bc60a050d5cefc9e307475e794.patch
}
build() {
@@ -84,7 +85,7 @@ build() {
runhaskell Setup configure -O --enable-shared --disable-library-vanilla \
--enable-executable-dynamic \
--prefix=/usr --docdir="/usr/share/doc/${pkgname}" \
- --libsubdir=\$compiler/site-local/\$pkgid \
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid \
-fnetwork-uri
runhaskell Setup build
runhaskell Setup register --gen-script
diff --git a/xmonad.hs.example b/xmonad.hs.example
new file mode 100644
index 000000000000..7533b7ee4ea5
--- /dev/null
+++ b/xmonad.hs.example
@@ -0,0 +1,19 @@
+module Main where
+
+import XMonad
+import XMonad.Hooks.EwmhDesktops (ewmh)
+import XMonad.Hooks.ManageDocks
+import System.Taffybar.Support.PagerHints (pagerHints)
+
+ -- xmonad entrypoint
+main = xmonad $
+
+ -- docks allows xmonad to handle taffybar
+ docks $
+
+ -- gives taffybar logger information
+ ewmh $
+ pagerHints
+
+ -- xmonad config
+ defaultConfig