summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorx1b6e62020-09-02 21:37:22 +0700
committerx1b6e62020-09-02 21:37:22 +0700
commit2c558ceb0e6093580af778d666ac56e75c5b8f79 (patch)
tree4f26d94c954a645dacf5417c3b8872d7e04464be
parenta8f521a60d3ffbe07dbe6ad3a5db9924256817d8 (diff)
downloadaur-2c558ceb0e6093580af778d666ac56e75c5b8f79.tar.gz
Edit help message
Signed-off-by: x1b6e6 <ftdabcde@gmail.com>
-rw-r--r--.SRCINFO6
-rw-r--r--CMakeLists.txt2
-rw-r--r--PKGBUILD6
-rw-r--r--aes.cc12
4 files changed, 14 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7f8137e8824d..b0cdf86a54ae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = aes
pkgdesc = encryption utility with very simple interface
- pkgver = 0.1.0
+ pkgver = 0.1.1
pkgrel = 1
url = https://github.com/x1b6e6/aes.git
arch = any
@@ -12,8 +12,8 @@ pkgbase = aes
depends = docopt
source = CMakeLists.txt
source = aes.cc
- sha1sums = 4c656edb9888276841ab1849084b5beeb7221f7a
- sha1sums = 6ab800f3769b1fcc393be977ba6eb32e750045cf
+ sha1sums = bbd6a785cd0c62baf7de7e6dcb9cd970678515fe
+ sha1sums = 10c4f9d10e133a1c2c13b91108e472c2e0da3287
pkgname = aes
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b07e9e9e51f3..0a985bf04e9a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,5 @@
cmake_minimum_required(VERSION 3.15)
-project(aes VERSION 0.1.0 LANGUAGES CXX)
+project(aes VERSION 0.1.1 LANGUAGES CXX)
add_definitions(-DPROJECT_VERSION="${PROJECT_VERSION}")
diff --git a/PKGBUILD b/PKGBUILD
index dbe962f2253c..9b97020a4e66 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: x1b6e6 <ftdabcde@gmail.com>
pkgname=aes
-pkgver=0.1.0
+pkgver=0.1.1
pkgrel=1
pkgdesc="encryption utility with very simple interface"
arch=('any')
@@ -16,8 +16,8 @@ source=(
)
sha1sums=(
- "4c656edb9888276841ab1849084b5beeb7221f7a"
- "6ab800f3769b1fcc393be977ba6eb32e750045cf"
+ "bbd6a785cd0c62baf7de7e6dcb9cd970678515fe"
+ "10c4f9d10e133a1c2c13b91108e472c2e0da3287"
)
build(){
diff --git a/aes.cc b/aes.cc
index 009cd0fd2853..75d1bf0a08da 100644
--- a/aes.cc
+++ b/aes.cc
@@ -27,11 +27,13 @@ Usage:
aes [options]
Options:
- -d, --decrypt decrypt data
- -p, --password=PASSWORD use password [default: prompt]
- -k, --key=KEY use key instead password [default: ]
- -l, --last=LAST size of last block [default: 0]
- -b, --bits=BITS use aes with specified bits [default: 256]
+ -h, --help Pring this message
+ -v, --version Print version and exit
+ -d, --decrypt Decrypt data
+ -p, --password=PASSWORD Use password [default: prompt]
+ -k, --key=KEY Use key instead password [default: ]
+ -l, --last=LAST Size of last block [default: 0]
+ -b, --bits=BITS Use aes with specified bits [default: 256]
)");
}