summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQuan Guo2015-06-17 21:31:06 +0200
committerQuan Guo2015-06-17 21:31:06 +0200
commit2c5632a858da7b4501d2060df7c93dc3a35741dc (patch)
treeea83ceb4fccbedc6162a2a17dbd943659c90cec7
downloadaur-2c5632a858da7b4501d2060df7c93dc3a35741dc.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..41dd77a8ce77
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-astroml
+ pkgdesc = AstroML is a Python module for machine learning and data mining built on numpy, scipy, scikit-learn, and matplotlib.
+ pkgver = 0.3
+ pkgrel = 1
+ url = http://www.astroml.org/
+ arch = any
+ license = BSD-3-Clause
+ depends = python-numpy
+ depends = python-scipy
+ depends = python-scikit-learn
+ depends = python-matplotlib
+ optdepends = astroml-examples
+ source = https://pypi.python.org/packages/source/a/astroML/astroML-0.3.tar.gz
+ md5sums = 56d5c281ca079eb569ef1898be1604db
+
+pkgname = python-astroml
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7b0292d680c7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Quan Guo <guotsuan@gmail.com>
+
+pkgname=python-astroml
+_pkgname=astroML
+pkgver=0.3
+pkgrel=1
+pkgdesc="AstroML is a Python module for machine learning and data mining built on numpy, scipy, scikit-learn, and matplotlib."
+
+url='http://www.astroml.org/'
+arch=('any')
+license=('BSD-3-Clause')
+depends=('python-numpy' 'python-scipy' 'python-scikit-learn'
+ 'python-matplotlib')
+
+optdepends=('astroml-examples')
+
+source=("https://pypi.python.org/packages/source/a/astroML/astroML-${pkgver}.tar.gz")
+
+md5sums=('56d5c281ca079eb569ef1898be1604db')
+
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python ./setup.py install --root="${pkgdir}" --prefix=/usr
+}