summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLloyd Henning2016-11-16 22:39:03 +0000
committerLloyd Henning2016-11-16 22:39:03 +0000
commit2c89210097a71d537e9d993278c467b39e8c7a69 (patch)
treec798254219cc8e7c639e59de8c161d5f08803359
downloadaur-2c89210097a71d537e9d993278c467b39e8c7a69.tar.gz
Initial commit of PKGBUILD with aruco 2.0.14
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bd44ca82cef8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = aruco
+ pkgdesc = Augmented reality library based on OpenCV
+ pkgver = 2.0.14
+ pkgrel = 1
+ url = https://www.uco.es/investiga/grupos/ava/node/26
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = cmake
+ source = http://downloads.sourceforge.net/aruco/aruco-2.0.14.zip
+ md5sums = 43aa2cd578732884b71c4a0264c413f8
+
+pkgname = aruco
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1e6518e17ff8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Lloyd Henning <lloyd.w.henning@gmail.com>
+pkgname=aruco
+pkgver=2.0.14
+pkgrel=1
+pkgdesc="Augmented reality library based on OpenCV"
+arch=('i686' 'x86_64')
+url="https://www.uco.es/investiga/grupos/ava/node/26"
+license=('BSD')
+makedepends=(cmake)
+source=("http://downloads.sourceforge.net/aruco/$pkgname-$pkgver.zip")
+md5sums=('43aa2cd578732884b71c4a0264c413f8')
+
+build() {
+ cd "$pkgname-$pkgver"
+ cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr .
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}