summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp Hentschel2021-07-06 00:58:34 +0200
committerPhilipp Hentschel2021-07-06 00:58:34 +0200
commit2cc386b50ccfd849c57c8a0abd7eec202ea48f18 (patch)
tree370c8e82ba35ec8666d7c4f26215ff63341346ed
parent73de490d50cbc5b82cd366a0a543b593f79035ea (diff)
downloadaur-2cc386b50ccfd849c57c8a0abd7eec202ea48f18.tar.gz
updated to 0.3.8
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD15
2 files changed, 14 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f5aa5e0a1cd1..b6dd76677383 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = apnotes
pkgdesc = Interface for Linux to View, Edit, Create and Sync Notes written on apple devices
- pkgver = 0.3.7
+ pkgver = 0.3.8
pkgrel = 1
url = https://github.com/findus/apnotes
arch = x86_64
@@ -8,9 +8,10 @@ pkgbase = apnotes
makedepends = rust
depends = sqlite
depends = openssl
- source = https://github.com/findus/apple-notes-bridge/archive/0.3.7/apnotes-0.3.7.tar.gz
+ depends = dbus
+ source = https://github.com/findus/apple-notes-bridge/archive/0.3.8/apnotes-0.3.8.tar.gz
validpgpkeys = 01938725ABC3812F5DBC219C6E19B9E46E818A5F
- sha256sums = a9732901aba8536526073a247ad28f2c86e50b869e8cb87fe39d204d1a6c8355
- sha512sums = 06072f8013ac4c71d139b9ccb3df6ca18cd4f7c551bc1f8d1dfe94fa022c901dc0be19409af6ea5c7945a5eaeee33d83cca7346fd4e3c254263901179b38cd6e
+ sha256sums = 1e0151a8ec7e70f29e56b26ad6b17638919cb895583141a08db036b7039c54b2
+ sha512sums = a603c54183c2a0ab5b38a4ed3115aad3cb7aefe8b6be92957a3a7fdd04873c6a288767a88a13c3b01dfc0a66773e0fd9985ff4d8c5727f1e6430cc69ee9033a6
pkgname = apnotes
diff --git a/PKGBUILD b/PKGBUILD
index bff6883a7c57..bafa135f35ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Philipp Hentschel <aur[at]f1ndus[dot]de>
pkgname=apnotes
-pkgver=0.3.7
+pkgver=0.3.8
pkgrel=1
pkgdesc='Interface for Linux to View, Edit, Create and Sync Notes written on apple devices'
url='https://github.com/findus/apnotes'
arch=('x86_64')
license=('MIT')
makedepends=('rust')
-depends=('sqlite' 'openssl')
+depends=('sqlite' 'openssl' 'dbus')
source=(https://github.com/findus/apple-notes-bridge/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz)
-sha256sums=('a9732901aba8536526073a247ad28f2c86e50b869e8cb87fe39d204d1a6c8355')
-sha512sums=('06072f8013ac4c71d139b9ccb3df6ca18cd4f7c551bc1f8d1dfe94fa022c901dc0be19409af6ea5c7945a5eaeee33d83cca7346fd4e3c254263901179b38cd6e')
+sha256sums=('1e0151a8ec7e70f29e56b26ad6b17638919cb895583141a08db036b7039c54b2')
+sha512sums=('a603c54183c2a0ab5b38a4ed3115aad3cb7aefe8b6be92957a3a7fdd04873c6a288767a88a13c3b01dfc0a66773e0fd9985ff4d8c5727f1e6430cc69ee9033a6')
validpgpkeys=('01938725ABC3812F5DBC219C6E19B9E46E818A5F')
@@ -27,6 +27,9 @@ check() {
package() {
cd ${srcdir}/${pkgname}-${pkgver}
- install -Dm 755 target/release/apnotes-tui -t "${pkgdir}/usr/bin"
- install -Dm 755 target/release/apnotes -t "${pkgdir}/usr/bin"
+ echo $(pwd)
+ install -Dm755 target/release/apnotes-tui -t "${pkgdir}/usr/bin"
+ install -Dm755 target/release/apnotes -t "${pkgdir}/usr/bin"
+ install -Dm644 target/release/apnotes.1.gz -t "${pkgdir}/usr/share/man/man1"
+ install -Dm644 target/release/apnotes.5.gz -t "${pkgdir}/usr/share/man/man5"
}