summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAoibhinn Nic Aoidh2021-07-06 18:48:37 +0100
committerAoibhinn Nic Aoidh2021-07-06 18:48:37 +0100
commit2ccb2dd4b897412babb4f9bfeba1b6ce698577d7 (patch)
tree7aa866df88f223a7d2fed309c90d3db6bfaa0a73
downloadaur-2ccb2dd4b897412babb4f9bfeba1b6ce698577d7.tar.gz
inital commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD51
2 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..01b8138cf6db
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = htim-git
+ pkgdesc = Htop improved, htop with vim key bindings
+ pkgver = 3.0.6
+ pkgrel = 1
+ epoch = 1
+ url = https://gitlab.com/thelinuxguy9/htim
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = python
+ depends = ncurses
+ depends = libnl
+ optdepends = lsof: list open files for running process
+ optdepends = strace: attach to running process
+ provides = htop
+ conflicts = htop
+ options = !emptydirs
+ source = git+https://gitlab.com/thelinuxguy9/htim
+ sha256sums = SKIP
+
+pkgname = htim-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..426be2fd1433
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Aoibhinn Nic Aoidh <aoibhinn.nic.aoidh+aur@gmail.com>
+# Contributor: Yardena Cohen <yardenack at gmail dot com>
+
+gitname=htim
+pkgname=${gitname}-git
+pkgver=3.0.6
+pkgrel=1
+epoch=1
+pkgdesc="Htop improved, htop with vim key bindings"
+url="https://gitlab.com/thelinuxguy9/htim"
+license=('GPL')
+arch=('i686' 'x86_64')
+depends=(ncurses libnl)
+makedepends=('git' 'python')
+optdepends=('lsof: list open files for running process'
+ 'strace: attach to running process')
+provides=('htop')
+conflicts=('htop')
+options=('!emptydirs')
+source=("git+https://gitlab.com/thelinuxguy9/htim")
+sha256sums=('SKIP')
+
+# pkgver() {
+# cd "${srcdir}/${gitname}"
+# local ver="$(git describe --tags)"
+# printf "%s" "${ver//-/.}"
+# }
+
+prepare() {
+ cd "${srcdir}/${gitname}"
+
+ ./autogen.sh
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --enable-unicode \
+ --enable-openvz \
+ --enable-vserver
+}
+
+build() {
+ cd "${srcdir}/${gitname}"
+ make
+}
+
+package() {
+ cd "${srcdir}/${gitname}"
+ make DESTDIR="${pkgdir}" install
+}
+