summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcarl.george2015-09-10 09:04:53 -0500
committercarl.george2015-09-10 09:04:53 -0500
commit2cee7f0428a8a54f18f504adfd117f3c01b32676 (patch)
treefe50f24a85f81d7a4ac0a117c8703f3bf0b06c9d
parent9a79a89ef0ad986f69d4406335b06aee2b08b023 (diff)
downloadaur-2cee7f0428a8a54f18f504adfd117f3c01b32676.tar.gz
2.6.0-1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
2 files changed, 7 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 62a0c6812050..1745c46f452d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = python-swiftclient
pkgdesc = OpenStack Object Storage API Client Library
- pkgver = 2.5.0
- pkgrel = 3
+ pkgver = 2.6.0
+ pkgrel = 1
url = https://github.com/openstack/python-swiftclient
arch = any
license = Apache
makedepends = python-pbr>=0.11
makedepends = python2-pbr>=0.11
- source = https://pypi.python.org/packages/source/p/python-swiftclient/python-swiftclient-2.5.0.tar.gz
- sha256sums = 6efcbff0bf60521ef682068c10c2d8959d887f70ed84ccd2def9945e8e94560e
+ source = https://pypi.python.org/packages/source/p/python-swiftclient/python-swiftclient-2.6.0.tar.gz
+ sha256sums = f7344b2a66ec0518d97e262a083b7e30e41fc0eb8e50661dd300e29d3ea163c8
pkgname = python-swiftclient
depends = python-requests>=1.1
diff --git a/PKGBUILD b/PKGBUILD
index d9d9ed732c8e..e97f41ed3763 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,22 +5,17 @@ _module="${_name#python-}"
_cmd="${_module%client}"
pkgname=("python-${_module}" "python2-${_module}")
-pkgver="2.5.0"
-pkgrel="3"
+pkgver="2.6.0"
+pkgrel="1"
pkgdesc="OpenStack Object Storage API Client Library"
arch=("any")
url="https://github.com/openstack/${_name}"
license=("Apache")
makedepends=("python-pbr>=0.11" "python2-pbr>=0.11")
source=("https://pypi.python.org/packages/source/${_name:0:1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha256sums=('6efcbff0bf60521ef682068c10c2d8959d887f70ed84ccd2def9945e8e94560e')
+sha256sums=('f7344b2a66ec0518d97e262a083b7e30e41fc0eb8e50661dd300e29d3ea163c8')
prepare() {
- # currently the syntax in this file causes this build error:
- # error in setup command: 'tests_require' must be a string or list of strings
- # containing valid project/version requirement specifiers; Expected ',' or
- # end-of-list in mock>=1.0;python_version!='2.6' at ;python_version!='2.6'
- rm -r "${_name}-${pkgver}/test-requirements.txt"
cp -a "${srcdir}/${_name}-${pkgver}" "${srcdir}/${_name}-${pkgver}-python2"
# futures is only needed for python 2
sed -ri '/futures/d' "${_name}-${pkgver}/requirements.txt"