summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhirui Dai2024-04-28 14:36:40 -0700
committerZhirui Dai2024-04-28 14:36:40 -0700
commit2ceee49e73efa4d8f74e0203c40c9accd0c33e7d (patch)
tree6c3bfc7dadc56b2338b15a374d93524e97416218
parent3aec193047307d215ff945a7f0a432912f0c9f4c (diff)
downloadaur-2ceee49e73efa4d8f74e0203c40c9accd0c33e7d.tar.gz
add upstream patch
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2c9f0cdd2738..f6db2caf8f5e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -25,6 +25,8 @@ pkgbase = ros-noetic-qt-gui-cpp
depends = sip4
depends = python-sip4
source = ros-noetic-qt-gui-cpp-0.4.2.tar.gz::https://github.com/ros-visualization/qt_gui_core/archive/0.4.2.tar.gz
+ source = upstream.patch::https://github.com/ros-visualization/qt_gui_core/compare/0.4.2...melodic-devel.patch
sha256sums = fbc5a7b0a4da43f80e9216845aec2e247fac0a63512053c03a9f89024d026aad
+ sha256sums = SKIP
pkgname = ros-noetic-qt-gui-cpp
diff --git a/PKGBUILD b/PKGBUILD
index 3f7a09817d12..ae57a91164f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -37,8 +37,16 @@ depends=(
)
_dir="qt_gui_core-${pkgver}/qt_gui_cpp"
-source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros-visualization/qt_gui_core/archive/${pkgver}.tar.gz")
-sha256sums=('fbc5a7b0a4da43f80e9216845aec2e247fac0a63512053c03a9f89024d026aad')
+source=(
+ "${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros-visualization/qt_gui_core/archive/${pkgver}.tar.gz"
+ "upstream.patch"::"https://github.com/ros-visualization/qt_gui_core/compare/0.4.2...melodic-devel.patch"
+)
+sha256sums=('fbc5a7b0a4da43f80e9216845aec2e247fac0a63512053c03a9f89024d026aad' 'SKIP')
+
+prepare() {
+ cd ${srcdir}/qt_gui-core-${pkgver}
+ patch -Np1 -i ${srcdir}/upstream.patch
+}
build() {
# Use ROS environment variables.