summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2018-11-22 00:25:14 +0100
committerhaawda2018-11-22 00:25:14 +0100
commit2d04fa0217f3eb4dd045ccf49b00c9cb1255f60a (patch)
tree0570f3055544635ce75d32dbffaae64a9fd63dd6
parent75738825e98c515d3f760b5b0174629a2536faf0 (diff)
downloadaur-2d04fa0217f3eb4dd045ccf49b00c9cb1255f60a.tar.gz
rewrite
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD43
2 files changed, 27 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 961360d9d9af..7d5ffc0fe39f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
-# Generated by mksrcinfo v8
-# Fri Dec 15 20:33:37 UTC 2017
pkgbase = ccl-git
pkgdesc = The Clozure Common Lisp implementation
- pkgver = 4748.1944cfb3
+ pkgver = 1.12.dev.3.44.g8fa7fdfc
pkgrel = 1
+ epoch = 1
url = http://ccl.clozure.com/
- arch = i686
arch = x86_64
license = APACHE
makedepends = git
+ makedepends = subversion
depends = bash
optdepends = java-environment: for using emaple file jfli.jar
provides = common-lisp
diff --git a/PKGBUILD b/PKGBUILD
index 9d53b236545e..47a1fc572dff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,33 +2,38 @@
# Contributor: Rogof <rogof /at/ gmx /dot/ com>
pkgname=ccl-git
-pkgver=4748.1944cfb3
+epoch=1
+pkgver=1.12.dev.3.44.g8fa7fdfc
pkgrel=1
pkgdesc="The Clozure Common Lisp implementation"
url="http://ccl.clozure.com/"
license=('APACHE')
-arch=('i686' 'x86_64')
+arch=('x86_64')
depends=('bash')
optdepends=('java-environment: for using emaple file jfli.jar')
-makedepends=('git')
+makedepends=('git' 'subversion')
provides=('common-lisp' 'cl-asdf' 'ccl')
conflicts=('ccl-bin' 'ccl')
-[ "${CARCH}" = 'x86_64' ] && _arch=64
-[ "${CARCH}" = 'i686' ] && _arch=32
+_arch=64
source=("git+https://github.com/Clozure/ccl.git" http://svn.clozure.com/publicsvn/openmcl/trunk/source/scripts/get-binaries)
sha1sums=('SKIP'
'3160281c3c8ed63b0019fa00139026d9fdb3259e')
pkgver() {
cd ccl
- printf %s.%s $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+ git describe --tags|tr - .|cut -c2-
+ #printf %s.%s $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
}
-build() {
+prepare() {
+ sed -i "s+svn export+svn export --force+" get-binaries
cd ccl
chmod 700 ../get-binaries
../get-binaries linuxx86
- cd lisp-kernel/linuxx8664
+}
+
+build() {
+ cd ccl/lisp-kernel/linuxx8664
make
cd ../..
echo "(ccl:rebuild-ccl :full t)" | ./lx86cl$_arch --no-init --quiet --batch
@@ -38,27 +43,27 @@ package() {
cd ccl
# install data
- install -d "$pkgdir/usr/lib/$pkgname"
+ install -d "$pkgdir"/usr/lib/$pkgname
cp -a {compiler,level-*,lib*,lisp-kernel,objc-bridge,tools,xdump,lx86cl$_arch*} \
"$pkgdir"/usr/lib/$pkgname
# install examples
- install -d "$pkgdir/usr/share/$pkgname"
- cp -a examples "$pkgdir/usr/share/$pkgname"
+ install -d "$pkgdir"/usr/share/$pkgname
+ cp -a examples "$pkgdir"/usr/share/$pkgname
# install documentation
- install -d "$pkgdir/usr/share/doc/$pkgname"
- cp -a doc/* "$pkgdir/usr/share/doc/$pkgname"
+ install -d "$pkgdir"/usr/share/doc/$pkgname
+ cp -a doc/* "$pkgdir"/usr/share/doc/$pkgname
# remove unwanted files
- find "$pkgdir/usr/" -type d -name .svn -exec rm -rf '{}' +
- find "$pkgdir/usr/lib/$pkgname" -name '*.o' -exec rm -f '{}' +
- find "$pkgdir/usr/lib/$pkgname" -name '*.*fsl' -exec rm -f '{}' +
+ find "$pkgdir"/usr/ -type d -name .svn -exec rm -rf '{}' +
+ find "$pkgdir"/usr/lib/$pkgname -name '*.o' -exec rm -f '{}' +
+ find "$pkgdir"/usr/lib/$pkgname -name '*.*fsl' -exec rm -f '{}' +
# install frontend script
- mkdir -p "$pkgdir/usr/bin"
- cat > "$pkgdir/usr/bin/ccl" <<EOF
+ install -d "$pkgdir"/usr/bin
+ cat > "$pkgdir"/usr/bin/ccl <<EOF
#!/bin/sh
exec /usr/lib/$pkgname/lx86cl$_arch "\$@"
EOF
- chmod +x "$pkgdir/usr/bin/ccl"
+ chmod +x "$pkgdir"/usr/bin/ccl
}