summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Straube2016-11-18 19:29:07 +0100
committerMichael Straube2016-11-18 19:29:07 +0100
commit2d483cae2e21c9c209a7e10994242df6183da19b (patch)
tree3ee60dae666ceefbfa42952f698fe7e8081ca2f7
parent4106cbdd6412e2360e69ee3a990ede696ab8334a (diff)
downloadaur-2d483cae2e21c9c209a7e10994242df6183da19b.tar.gz
Make it a split pkg (theme + addon)
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD65
-rw-r--r--update-icon-cache.install14
-rw-r--r--update-manager-32.pngbin0 -> 1763 bytes
4 files changed, 66 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3a3ca744eb5a..86bfbf68cb0b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,24 @@
-# Generated by mksrcinfo v8
-# Thu Apr 14 13:51:44 UTC 2016
pkgbase = vivacious-colors
- pkgdesc = A vivid and modern GTK icon theme. Featuring a completely NEW set of application icons (Re-designed by RAVEfinity based on Plasma-Next, Flattr and Emerald).
+ pkgdesc = A vivid and modern GTK icon theme
pkgver = 1.4
pkgrel = 1
url = http://www.ravefinity.com/p/vivacious-colors-gtk-icon-theme.html
- install = update-icon-cache.install
arch = any
- license = custom:cc-by-sa-3.0
+ license = CCPL:by-sa
license = GPL2
+ noextract = vivacious-colors-icon-theme-1.4.tar.gz
+ noextract = vivacious-colors-folder-addon-1.4.tar.gz
options = !strip
- options = !zipman
- options = libtool
- options = staticlibs
- source = vivacious-colors-1.4.tar.gz::https://googledrive.com/host/0B7iDWdwgu9QAdFNoQ1ZpaGZJSkU
- md5sums = a6007d920f70af7bd65e721bc9b6b218
+ source = vivacious-colors-icon-theme-1.4.tar.gz::https://drive.google.com/uc?export=download&id=0B7iDWdwgu9QAdFNoQ1ZpaGZJSkU
+ source = vivacious-colors-folder-addon-1.4.tar.gz::https://drive.google.com/uc?export=download&id=0B7iDWdwgu9QAbXlKT2lRT3VBdzA
+ source = update-manager-32.png
+ sha256sums = 31b1a44bf9c7aa517a0bdf4150ab8005da21ba011e3b409501deaa80152e4af5
+ sha256sums = d0d181cabfede9e8cfce8f4abb151be8dd759fa08b9b7b077e61ea44abaf7659
+ sha256sums = 33fb762bc15b11ee542fc5ce425f26fa253a97557bacadd0f3e175a47af7d99c
-pkgname = vivacious-colors
+pkgname = vivacious-colors-icon-theme
+
+pkgname = vivacious-colors-folder-addon
+ pkgdesc = Additional folder colors for the vivacious-colors icon theme
+ depends = vivacious-colors-icon-theme
diff --git a/PKGBUILD b/PKGBUILD
index f57fb655b341..0d43d101a0fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,57 @@
# Maintainer: ThePilot <afuturepilotis at gmail dot com>
-pkgname=vivacious-colors
+
+pkgbase=vivacious-colors
+pkgname=("$pkgbase-icon-theme" "$pkgbase-folder-addon")
pkgver=1.4
pkgrel=1
-pkgdesc="A vivid and modern GTK icon theme. Featuring a completely NEW set of application icons (Re-designed by RAVEfinity based on Plasma-Next, Flattr and Emerald)."
+pkgdesc="A vivid and modern GTK icon theme"
arch=('any')
url="http://www.ravefinity.com/p/vivacious-colors-gtk-icon-theme.html"
-license=('custom:cc-by-sa-3.0' 'GPL2')
-options=('!strip' '!zipman' 'libtool' 'staticlibs')
-install=update-icon-cache.install
-source=($pkgname-$pkgver.tar.gz::https://googledrive.com/host/0B7iDWdwgu9QAdFNoQ1ZpaGZJSkU)
-md5sums=('a6007d920f70af7bd65e721bc9b6b218')
-
-package() {
- mkdir -p $pkgdir/usr/share/icons/
- cp -r $srcdir/* $pkgdir/usr/share/icons/
- mkdir -p $pkgdir/usr/share/licenses/vivacious-colors/
- mv "$pkgdir/usr/share/icons/Copyrights&Licenses.txt" "$pkgdir/usr/share/licenses/vivacious-colors/"
- rm "$pkgdir/usr/share/icons/README-Manual.txt" "$pkgdir/usr/share/icons/$pkgname-$pkgver.tar.gz"
+license=('CCPL:by-sa' 'GPL2')
+options=('!strip')
+noextract=("$pkgbase-icon-theme-$pkgver.tar.gz"
+ "$pkgbase-folder-addon-$pkgver.tar.gz")
+source=("$pkgbase-icon-theme-$pkgver.tar.gz::https://drive.google.com/uc?export=download&id=0B7iDWdwgu9QAdFNoQ1ZpaGZJSkU"
+ "$pkgbase-folder-addon-$pkgver.tar.gz::https://drive.google.com/uc?export=download&id=0B7iDWdwgu9QAbXlKT2lRT3VBdzA"
+ "update-manager-32.png")
+sha256sums=('31b1a44bf9c7aa517a0bdf4150ab8005da21ba011e3b409501deaa80152e4af5'
+ 'd0d181cabfede9e8cfce8f4abb151be8dd759fa08b9b7b077e61ea44abaf7659'
+ '33fb762bc15b11ee542fc5ce425f26fa253a97557bacadd0f3e175a47af7d99c')
+
+prepare() {
+ mkdir $pkgbase-icon-theme-$pkgver
+ tar -xf $pkgbase-icon-theme-$pkgver.tar.gz -C $pkgbase-icon-theme-$pkgver
+
+ mkdir $pkgbase-folder-addon-$pkgver
+ tar -xf $pkgbase-folder-addon-$pkgver.tar.gz -C $pkgbase-folder-addon-$pkgver
+}
+
+package_vivacious-colors-icon-theme() {
+ cd $pkgbase-icon-theme-$pkgver
+
+ install -d "$pkgdir"/usr/share/icons
+ cp -r Vivacious-* "$pkgdir"/usr/share/icons
+
+ install -Dm644 "Copyrights&Licenses.txt" \
+ "$pkgdir/usr/share/licenses/$pkgbase-icon-theme/Copyrights&Licenses.txt"
+
+ # fix permissions
+ chmod 644 "$pkgdir"/usr/share/icons/Vivacious-Colors-Full-Dark/actions/scalable/go-home.svg
+ chmod 644 "$pkgdir"/usr/share/icons/Vivacious-Colors-Full-Dark/actions/scalable/document-open-recent.svg
+
+ # add missing icon
+ install -m 644 ../update-manager-32.png "$pkgdir"/usr/share/icons/Vivacious-Colors-Dark/apps/32/update-manager.png
+}
+
+package_vivacious-colors-folder-addon() {
+ pkgdesc="Additional folder colors for the vivacious-colors icon theme"
+ depends=('vivacious-colors-icon-theme')
+
+ cd $pkgbase-folder-addon-$pkgver
+
+ install -d "$pkgdir"/usr/share/icons
+ cp -r Vivacious-* "$pkgdir"/usr/share/icons
+
+ install -Dm644 "Copyrights&Licenses.txt" \
+ "$pkgdir/usr/share/licenses/$pkgbase-folder-addon/Copyrights&Licenses.txt"
}
diff --git a/update-icon-cache.install b/update-icon-cache.install
deleted file mode 100644
index 691b68835bf4..000000000000
--- a/update-icon-cache.install
+++ /dev/null
@@ -1,14 +0,0 @@
-post_install() {
- for dir in usr/share/icons/Vivacious*; do
- gtk-update-icon-cache -ftq $dir
- done
-}
-
-post_upgrade() {
- post_install
-}
-
-post_remove() {
- post_install
-}
-
diff --git a/update-manager-32.png b/update-manager-32.png
new file mode 100644
index 000000000000..dd7b02d83444
--- /dev/null
+++ b/update-manager-32.png
Binary files differ