summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2016-02-03 14:06:38 +0100
committerPhilipp A2016-02-03 14:06:38 +0100
commit2d4f4c51935b7c9f07c1086e48394f78f0dccbfa (patch)
tree78b254c7cd21a3939f20276a391dab5d1a372c41
parent2c96170125df970f72bfeb320392117f0312b573 (diff)
downloadaur-2d4f4c51935b7c9f07c1086e48394f78f0dccbfa.tar.gz
v2.1.1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 70a25c7a6e1a..6feca5b58d9d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = unicodemoticon
pkgdesc = Like a Color Picker but for Unicode Emoticons. Trayicon with Unicode Emoticons using Python3 Qt5.
- pkgver = 2.0.0
+ pkgver = 2.1.1
pkgrel = 1
url = https://github.com/juancarlospaco/unicodemoticon
arch = any
@@ -9,8 +9,8 @@ pkgbase = unicodemoticon
depends = python
depends = python-pyqt5
optdepends = ttf-symbola: Font with emoji
- source = https://pypi.python.org/packages/source/u/unicodemoticon/unicodemoticon-2.0.0.zip
- md5sums = 769a027b859cc937b20d540ca83ff2ce
+ source = https://github.com/juancarlospaco/unicodemoticon/archive/2.1.1.tar.gz
+ sha256sums = 3603a6f771d86d8dc847405810cec9a694da5b0b1eb74f9135eb67dc0497c5e2
pkgname = unicodemoticon
diff --git a/PKGBUILD b/PKGBUILD
index 717f4108f750..25456201df03 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=unicodemoticon
-pkgver=2.0.0
+pkgver=2.1.1
pkgrel=1
pkgdesc="Like a Color Picker but for Unicode Emoticons. Trayicon with Unicode Emoticons using Python3 Qt5."
url="https://github.com/juancarlospaco/unicodemoticon"
@@ -8,15 +8,13 @@ optdepends=('ttf-symbola: Font with emoji')
makedepends=('python-distribute')
license=('GPL')
arch=('any')
-source=("https://pypi.python.org/packages/source/u/$pkgname/$pkgname-$pkgver.zip")
-md5sums=('769a027b859cc937b20d540ca83ff2ce')
+source=("https://github.com/juancarlospaco/$pkgname/archive/$pkgver.tar.gz")
+sha256sums=('3603a6f771d86d8dc847405810cec9a694da5b0b1eb74f9135eb67dc0497c5e2')
build() {
cd "$srcdir/$pkgname-$pkgver"
python setup.py build
-
- python -c 'import unicodemoticon; print(unicodemoticon.AUTOSTART_DESKTOP_FILE)' > unicodemoticon.desktop
}
@@ -24,5 +22,5 @@ package() {
cd "$srcdir/$pkgname-$pkgver"
python setup.py install --root="$pkgdir" --optimize=1
- install -Dm755 unicodemoticon.desktop "$pkgdir/usr/share/applications/unicodemoticon.desktop"
+ install -Dm755 unicodemoticon/unicodemoticon.desktop "$pkgdir/usr/share/applications/unicodemoticon.desktop"
}