summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJstKddng2019-07-08 11:29:28 -0500
committerJstKddng2019-07-08 11:29:28 -0500
commit2d50346364285a1429f39459067e99f1eb33304e (patch)
tree75229e1506b8467856d619321b839db5a60af1e8
downloadaur-2d50346364285a1429f39459067e99f1eb33304e.tar.gz
Initial commit
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD39
-rw-r--r--no-simd.patch13
3 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d52403887ac4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = python-ueberzug-nosimd-git
+ pkgdesc = ueberzug is an python script which aims to replace w3mimgdisplay
+ pkgver = 18.1.3.r12.g5f3790e
+ pkgrel = 1
+ url = https://github.com/seebye/ueberzug
+ arch = any
+ license = GPL3
+ makedepends = python
+ makedepends = git
+ makedepends = python-setuptools
+ depends = libxext
+ depends = python-pillow
+ depends = python
+ depends = python-xlib
+ depends = python-docopt
+ depends = python-psutil
+ depends = python-attrs
+ depends = git
+ provides = python-ueberzug
+ conflicts = python-ueberzug
+ source = git+https://github.com/seebye/ueberzug.git#branch=master
+ source = no-simd.patch
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = python-ueberzug-nosimd-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dff3d8725c27
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: JustKidding <jk at vin dot ovh>
+
+_pkgname=ueberzug
+pkgname=python-${_pkgname}-nosimd-git
+pkgver=18.1.3.r12.g5f3790e
+pkgrel=1
+pkgdesc="ueberzug is an python script which aims to replace w3mimgdisplay"
+arch=('any')
+url="https://github.com/seebye/${_pkgname}"
+license=('GPL3')
+depends=("libxext" "python-pillow" "python" "python-xlib" "python-docopt" "python-psutil" "python-attrs"
+ "git")
+makedepends=("python" "git" "python-setuptools")
+source=("git+${url}.git#branch=master"
+ "no-simd.patch")
+md5sums=('SKIP'
+ "SKIP")
+conflicts=("python-${_pkgname}")
+provides=("python-${_pkgname}")
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "$srcdir/$_pkgname"
+ patch --forward --strip=1 --input="${srcdir}/no-simd.patch"
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ python setup.py install --prefix=/usr --root "${pkgdir}" || return 1
+}
diff --git a/no-simd.patch b/no-simd.patch
new file mode 100644
index 000000000000..e407031a2b93
--- /dev/null
+++ b/no-simd.patch
@@ -0,0 +1,13 @@
+diff --git a/setup.py b/setup.py
+index 81d036b..659fc33 100755
+--- a/setup.py
++++ b/setup.py
+@@ -94,7 +94,7 @@ setuptools.setup(
+ #
+ # For an analysis of "install_requires" vs pip's requirements files see:
+ # https://packaging.python.org/en/latest/requirements.html
+- install_requires=['python-xlib', 'pillow-simd', 'docopt',
++ install_requires=['python-xlib', 'pillow', 'docopt',
+ 'psutil', 'attrs'], # Optional
+ python_requires='>=3.5',
+